Impact
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a cross‑site scripting flaw that allows a remote authenticated attacker to inject and execute malicious scripts. Certain URL fields are not sufficiently validated, permitting script content to run in another user’s browser session and potentially enabling session hijacking or data theft.
Affected Systems
Systems running IBM API Connect 10.0.8.0 to 10.0.8.12 or 12.1.0.0 to 12.1.1.2 are affected. IBM has released patched versions 10.0.8.13 and 12.1.1.3; upgrading to either of these fixes the vulnerability.
Risk and Exploitability
The CVSS score of 5.4 indicates medium severity, and the EPSS score is not available. The vulnerability is not listed in the CISA KEV catalog. Because authentication is required, attackers with valid credentials – including insiders or those who have stolen credentials – can exploit the XSS vector, compromising user sessions and potentially exfiltrating data. Until the patched release is deployed, the risk remains present.
OpenCVE Enrichment