Description
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to gain elevated privileges due to improper authentication.
Published: 2026-11-07
Score: 9.9 Critical
EPSS: < 1% Very Low
KEV: No
Impact: Privilege Escalation via Improper Authentication
Action: Immediate Patch
AI Analysis

Impact

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain an improper authentication flaw that can allow an attacker who is already authenticated to gain elevated privileges. This flaw enables the attacker to bypass intended authorization controls, potentially accessing or modifying data and configuration that should be restricted, thereby compromising confidentiality, integrity, and availability of the API Connect environment.

Affected Systems

The affected products are IBM API Connect. Versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 are vulnerable to the described privilege escalation.

Risk and Exploitability

The vulnerability has a CVSS score of 9.9, reflecting a high severity. The EPSS score is not available, but the lack of a KEV listing does not reduce the risk; the flaw can be exploited by any remote party that already has authenticated access, allowing immediate privilege escalation within the affected systems. The likely attack vector is a remote authenticated user taking advantage of the authentication weakness to elevate their privileges.

Generated by OpenCVE AI on November 7, 2026 at 06:59 UTC.

Remediation

Vendor Solution

IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3 Fix Central Link: https://www.ibm.com/support/pages/node/7290205 IBM strongly recommends addressing the vulnerability now by upgrading to 10.0.8.13Fix Central Link: https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%7EWebSphere&product=ibm/WebSphere/IBM+API+Connect&release=10.0.8.12&platform=All&function=all


OpenCVE Recommended Actions

  • Upgrade IBM API Connect to version 10.0.8.13 or 12.1.1.3, which contains the fix for the authentication defect.
  • Ensure that all users are assigned the least privilege necessary for their roles to limit the impact of any remaining authentication issues.
  • Implement monitoring for anomalous privilege changes and enforce strict audit logging to detect unauthorized privilege escalation attempts.

Generated by OpenCVE AI on November 7, 2026 at 06:59 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 04:45:00 +0000

Type Values Removed Values Added
Description IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to gain elevated privileges due to improper authentication.
Title Multiple Vulnerabilities in IBM API Connect
First Time appeared Ibm
Ibm api Connect
Weaknesses CWE-287
CPEs cpe:2.3:a:ibm:api_connect:10.0.8.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:api_connect:10.0.8.12:*:*:*:*:*:*:*
cpe:2.3:a:ibm:api_connect:12.1.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:api_connect:12.1.1.2:*:*:*:*:*:*:*
Vendors & Products Ibm
Ibm api Connect
References
Metrics cvssV3_1

{'score': 9.9, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H'}


cve-icon MITRE

Status: PUBLISHED

Assigner: ibm

Published:

Updated: 2026-11-07T04:32:06.015Z

Reserved: 2026-07-24T17:48:02.987Z

Link: CVE-2026-17158

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Awaiting Analysis

Published: 2026-11-07T05:18:28.853

Modified: 2026-11-07T05:18:29.003

Link: CVE-2026-17158

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T07:00:15Z

Weaknesses