Impact
IBM API Connect versions 12.1.0.0 through 12.1.1.2 were found to improperly trust client supplied data when creating audit entries. This flaw allows a remote attacker with valid credentials to insert misleading or false audit log entries, undermining the integrity of event tracing and potentially concealing malicious activity. The weakness is an example of Authenticated remote log injection, identified as CWE‑807.
Affected Systems
Vulnerable versions are IBM API Connect 12.1.0.0 and 12.1.1.2. The affected product is IBM API Connect, as enumerated in the CNA vendor list. All installations running these releases are susceptible unless migrated to the fixed 12.1.1.3 release.
Risk and Exploitability
The vulnerability requires authentication, so only users with legitimate credentials can exploit it. The CVSS score of 4.3 indicates a moderate impact on the integrity of audit records. No EPSS score is reported, and the flaw is not listed in CISA's KEV catalog, so the overall likelihood of exploitation is unclear. Attackers could use the falsified logs to hide intrusion attempts or mislead incident responders.
OpenCVE Enrichment