Description
IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper input validation. Locations supplied when service definitions are imported are not sufficiently validated, which could allow the server to retrieve content it should not access.
Published: 2026-11-07
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Sensitive Information Disclosure
Action: Patch Now
AI Analysis

Impact

IBM API Connect 12.1.0.0 through 12.1.1.2 contain a flaw in input validation (CWE-918) that occurs when service definitions are imported. A remote attacker who is authenticated with appropriate credentials can supply potentially malicious input, causing the server to read and return content that it should not have access to, thereby exposing sensitive data.

Affected Systems

The vulnerability affects IBM API Connect version 12.1.0.0 up through 12.1.1.2. These versions are listed as vulnerable in the affected product identifiers.

Risk and Exploitability

The CVSS score of 6.4 indicates moderate severity. The EPSS score is not available, and the vulnerability is not listed in the CISA KEV catalog. The flaw requires remote authenticated access, which is the likely attack vector; an attacker with legitimate credentials could exploit the lack of proper validation to retrieve unauthorized data.

Generated by OpenCVE AI on November 7, 2026 at 07:09 UTC.

Remediation

Vendor Solution

IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3 Fix Central Link: https://www.ibm.com/support/pages/node/7290205


OpenCVE Recommended Actions

  • Upgrade IBM API Connect to version 12.1.1.3 as the vendor recommends
  • Configure the system to allow imports only from trusted, authenticated sources
  • Implement additional input validation to enforce strict access control during service definition import

Generated by OpenCVE AI on November 7, 2026 at 07:09 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 04:45:00 +0000

Type Values Removed Values Added
Description IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper input validation. Locations supplied when service definitions are imported are not sufficiently validated, which could allow the server to retrieve content it should not access.
Title Multiple Vulnerabilities in IBM API Connect
First Time appeared Ibm
Ibm api Connect
Weaknesses CWE-918
CPEs cpe:2.3:a:ibm:api_connect:12.1.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:api_connect:12.1.1.2:*:*:*:*:*:*:*
Vendors & Products Ibm
Ibm api Connect
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


cve-icon MITRE

Status: PUBLISHED

Assigner: ibm

Published:

Updated: 2026-11-07T04:32:55.885Z

Reserved: 2026-07-25T01:06:32.335Z

Link: CVE-2026-17304

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Awaiting Analysis

Published: 2026-11-07T05:18:38.477

Modified: 2026-11-07T05:18:38.607

Link: CVE-2026-17304

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T12:00:15Z

Weaknesses
  • CWE-918

    Server-Side Request Forgery (SSRF)