Impact
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a flaw that allows a local attacker to read sensitive credentials from log files. The vulnerability is a case of data leakage via logging (CWE-532). If exploited, an attacker can capture authentication information and use it to compromise or impersonate user accounts, thereby affecting confidentiality and potentially availability of services.
Affected Systems
IBM API Connect infrastructure running the affected releases—10.0.8.0 to 10.0.8.12 and 12.1.0.0 to 12.1.1.2—is impacted. IBM recommends upgrading to the fixed releases 10.0.8.13 or 12.1.1.3 to eliminate this issue.
Risk and Exploitability
The CVSS score of 7.1 indicates a moderate‑to‑high severity. The EPSS score is not available, so the exact probability of exploitation is unknown, but the vulnerability is not listed in the CISA KEV catalog. An attacker requires local access to the API Connect deployment to read the log files, making the attack vector local. Once credentials are disclosed, the attacker can presume arbitrary account access, which can cascade to broader system compromise. Therefore, timely remediation is advised.
OpenCVE Enrichment