Description
IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper input validation. Input checks are incomplete, which could allow them to be bypassed.
Published: 2026-11-07
Score: 8.5 High
EPSS: n/a
KEV: No
Impact: Data Exposure
Action: Immediate Patch
AI Analysis

Impact

IBM API Connect versions 12.1.0.0 through 12.1.1.2 contain improper input validation that allows a remote authenticated attacker to retrieve sensitive information by bypassing incomplete input checks. The vulnerability is an information disclosure flaw that compromises confidentiality and could reveal credentials, design data or other protected material. Attackers with valid authentication credentials are required to exploit the flaw, but once authenticated they can access data beyond what their role should allow.

Affected Systems

The affected product is IBM API Connect. All installations of version 12.1.0.0 and 12.1.1.2 are vulnerable. Users running these versions should verify that they are not exposed to the vulnerability.

Risk and Exploitability

The CVSS score of 8.5 indicates a high severity. Because EPSS is not available, the current exploitation probability cannot be quantified but the lack of a KEV listing suggests no known large‑scale active exploitation. The vulnerability can be exploited by an authenticated attacker with any type of user role; therefore, a privileged account or a compromised account can be used to extract sensitive data. The lack of a public exploit reduces but does not eliminate the need for remediation.

Generated by OpenCVE AI on November 7, 2026 at 06:24 UTC.

Remediation

Vendor Solution

IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3 Fix Central Link: https://www.ibm.com/support/pages/node/7290205


OpenCVE Recommended Actions

  • Upgrade IBM API Connect to version 12.1.1.3 as recommended by IBM
  • Verify the application no longer accepts the validated inputs that trigger the vulnerability
  • Restrict authenticated users to the minimal privileges required for their function to limit potential data exposure

Generated by OpenCVE AI on November 7, 2026 at 06:24 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 04:45:00 +0000

Type Values Removed Values Added
Description IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper input validation. Input checks are incomplete, which could allow them to be bypassed.
Title Multiple Vulnerabilities in IBM API Connect
First Time appeared Ibm
Ibm api Connect
Weaknesses CWE-918
CPEs cpe:2.3:a:ibm:api_connect:12.1.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:api_connect:12.1.1.2:*:*:*:*:*:*:*
Vendors & Products Ibm
Ibm api Connect
References
Metrics cvssV3_1

{'score': 8.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N'}


cve-icon MITRE

Status: PUBLISHED

Assigner: ibm

Published:

Updated: 2026-11-07T04:33:20.854Z

Reserved: 2026-07-25T02:12:10.371Z

Link: CVE-2026-17328

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Awaiting Analysis

Published: 2026-11-07T05:18:43.083

Modified: 2026-11-07T05:18:43.233

Link: CVE-2026-17328

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T06:30:14Z

Weaknesses
  • CWE-918

    Server-Side Request Forgery (SSRF)