Description
The Premium Packages – Sell Digital Products Securely plugin for WordPress is vulnerable to Unauthenticated Stored Cross-Site Scripting via 'order_email' in all versions up to, and including, 7.0.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-15
Score: 7.2 High
EPSS: < 1% Very Low
KEV: No
Impact: Unauthenticated Stored Cross‑Site Scripting (XSS)
Action: Immediate Patch
AI Analysis

Impact

This vulnerability enables an unauthenticated attacker to inject arbitrary JavaScript into the "order_email" field of the Premium Packages – Sell Digital Products Securely plugin. The injected script is stored and will execute in the browser whenever a user views a page that displays the affected order, potentially allowing the attacker to steal session cookies, deface the site, or perform phishing attacks. The weakness is a classic input sanitization flaw that fails to escape or validate user‑supplied content, allowing malicious code to persistently reside within the database.

Affected Systems

Any WordPress installation that has installed the Premium Packages plugin in a version up to and including 7.0.5 is affected. Site administrators using this plugin to sell digital products must verify their installed version and consider the plugin a critical component of the site’s attack surface.

Risk and Exploitability

With a CVSS score of 7.2 the vulnerability is classified as high severity. Exploitation does not require authentication, meaning any internet‑visible user can submit a crafted "order_email" entry. The EPSS score is not available, and the vulnerability is not currently listed in CISA's KEV database, but the lack of authentication barrier and the potential for widespread impact elevate the risk for exposed WordPress sites that have not upgraded the plugin.

Generated by OpenCVE AI on October 15, 2026 at 11:24 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Premium Packages plugin to a version newer than 7.0.5 to apply the vendor patch.
  • If an upgrade cannot be performed immediately, locate and remove or sanitize any orders stored in the database that contain the malicious "order_email" payload to eliminate the stored XSS vectors.
  • Deploy a content‑security policy or WAF rules that block unexpected script execution to reduce the impact of any remaining injected code.

Generated by OpenCVE AI on October 15, 2026 at 11:24 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 17 Oct 2026 16:45:00 +0000

Type Values Removed Values Added
First Time appeared Codename065
Codename065 premium Packages – Sell Digital Products Securely
Wordpress-extensions
Wordpress-extensions premium Packages
Vendors & Products Codename065
Codename065 premium Packages – Sell Digital Products Securely
Wordpress-extensions
Wordpress-extensions premium Packages

Thu, 15 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 15 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The Premium Packages – Sell Digital Products Securely plugin for WordPress is vulnerable to Unauthenticated Stored Cross-Site Scripting via 'order_email' in all versions up to, and including, 7.0.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title Premium Packages <= 7.0.5 - Unauthenticated Stored Cross-Site Scripting via 'order_email'
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.2, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

Codename065 Premium Packages – Sell Digital Products Securely
Wordpress-extensions Premium Packages
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-15T16:43:41.179Z

Reserved: 2026-08-02T19:45:25.828Z

Link: CVE-2026-18586

cve-icon Vulnrichment

Updated: 2026-10-15T16:38:09.291Z

cve-icon NVD

Status : Deferred

Published: 2026-10-15T06:17:03.347

Modified: 2026-10-15T17:17:21.433

Link: CVE-2026-18586

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-17T16:30:07Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')