Description
IBM CockroachDB PostgreSQL for IBM VPC 26.2.0 through 26.2.3, 25.4.0 through 25.4.12, and 25.2.0 through 25.2.20 is vulnerable to privilege escalation via user-defined function.
Published: 2026-11-08
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Privilege Escalation via user‑defined functions
Action: Immediate Patch
AI Analysis

Impact

IBM CockroachDB PostgreSQL for IBM VPC versions 25.2.0 through 25.2.20, 25.4.0 through 25.4.12, and 26.2.0 through 26.2.3 are vulnerable to privilege escalation by leveraging a user‑defined function. The flaw allows a database user with the ability to create or modify such functions to obtain higher‑level privileges, potentially accessing or altering data beyond their intended scope.

Affected Systems

Products affected are IBM CockroachDB PostgreSQL for IBM VPC, spanning the three major releases cited above. Any deployment of these versions running on IBM VPC is at risk.

Risk and Exploitability

The CVSS score of 7.1 indicates a medium‑to‑high severity. EPSS is not available, but the vulnerability is not listed in the CISA KEV catalog. The likely attack vector involves a user who can define functions in the database; consequently, the exploitation requires some level of SQL access. If that privilege exists, an attacker can gain elevated rights and compromise data confidentiality, integrity, and availability.

Generated by OpenCVE AI on November 8, 2026 at 19:26 UTC.

Remediation

Vendor Solution

For CockroachDB PostgreSQL for IBM VPC, upgrade to CockroachDB 25.2.20, 25.4.12 or 26.2.3. Download the product versions from IBM Passport Advantage Online.


OpenCVE Recommended Actions

  • Upgrade CockroachDB PostgreSQL for IBM VPC to version 25.2.20, 25.4.12, or 26.2.3 as recommended by IBM.
  • If an upgrade is pending, restrict or disable the ability to create user‑defined functions for non‑admin roles.
  • Audit database roles and permissions regularly, and monitor for unexpected user‑defined function creation.

Generated by OpenCVE AI on November 8, 2026 at 19:26 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 08 Nov 2026 18:30:00 +0000

Type Values Removed Values Added
Description IBM CockroachDB PostgreSQL for IBM VPC 26.2.0 through 26.2.3, 25.4.0 through 25.4.12, and 25.2.0 through 25.2.20 is vulnerable to privilege escalation via user-defined function.
Title CockroachDB PostgreSQL for IBM VPC is affected by multiple vulnerabilities
First Time appeared Ibm
Ibm cockroachdb Postgresql For Ibm Vpc
Weaknesses CWE-269
CPEs cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:25.2.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:25.2.20:*:*:*:*:*:*:*
cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:25.4.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:25.4.12:*:*:*:*:*:*:*
cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:26.2.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:26.2.3:*:*:*:*:*:*:*
Vendors & Products Ibm
Ibm cockroachdb Postgresql For Ibm Vpc
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N'}


Subscriptions

Ibm Cockroachdb Postgresql For Ibm Vpc
cve-icon MITRE

Status: PUBLISHED

Assigner: ibm

Published:

Updated: 2026-11-08T18:08:42.430Z

Reserved: 2026-08-04T19:50:01.095Z

Link: CVE-2026-18893

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Awaiting Analysis

Published: 2026-11-08T19:17:38.380

Modified: 2026-11-08T19:17:38.500

Link: CVE-2026-18893

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-08T19:30:12Z

Weaknesses
  • CWE-269

    Improper Privilege Management