Impact
IBM API Connect 12.1.0.0 through 12.1.1.2 includes an improper authorization flaw that allows an authenticated attacker to view or modify resources belonging to another tenant. The vulnerability derives from tenant context not being sufficiently verified against the authenticated user, resulting in cross‑tenant data exposure or tampering. This weakness is identified as CWE‑290.
Affected Systems
All IBM API Connect deployments running versions 12.1.0.0 to 12.1.1.2 are susceptible. Users should confirm their product version and plan an upgrade past 12.1.1.2 to mitigate risk.
Risk and Exploitability
The CVSS score of 8.3 signifies a high severity. EPSS data is not available, so the current probability of exploitation is uncertain. The vulnerability is not listed in CISA’s KEV catalog. Attackers must be authenticated; once authenticated they can override tenant boundaries and access cross‑tenant resources, potentially compromising data confidentiality and integrity across multiple tenants.
OpenCVE Enrichment