Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CozyThemes Cozy Blocks cozy-addons allows Stored XSS.This issue affects Cozy Blocks: from n/a through 2.2.27.
Published: 2026-10-29
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch Now
AI Analysis

Impact

The CozyBlocks plugin includes a stored cross‑site scripting flaw that fails to neutralize user input when generating web pages. Because the malicious code is saved and later rendered for any visitor, an attacker can inject JavaScript that runs in the browser context of other users. This weakness can lead to credential theft, session hijacking, or defacement of the site, and is classified as CWE‑79.

Affected Systems

WordPress sites using the CozyThemes Cozy Blocks plugin in any version up to and including 2.2.27 are affected. The vulnerability originates from the plugin’s handling of content within the Cozy‑Addons module.

Risk and Exploitability

The CVSS score of 6.5 indicates a moderate severity. The EPSS score is not available, so the known exploitation probability is uncertain. The vulnerability is not listed in the CISA KEV catalog. Based on the stored‑XSS nature of the flaw, the likely attack vector is an attacker who gains write access to a post or content area where the plugin renders data—this could be through the plugin’s configuration UI or ordinary content editing. No additional conditions are described, suggesting that the flaw can be exploited as long as the vulnerable plugin is installed and operational.

Generated by OpenCVE AI on October 29, 2026 at 16:11 UTC.

Remediation

Vendor Solution

Update the WordPress Cozy Blocks plugin to the latest available version (at least 2.2.28).


OpenCVE Recommended Actions

  • Update Cozy Blocks to version 2.2.28 or newer, which removes the stored XSS flaw.
  • Clean all stored content that may contain injected JavaScript, ensuring only sanitized HTML remains.
  • Deploy a web application firewall or CMS configuration that blocks malformed or unsafe scripts before rendering, using the official WAF solutions for WordPress.

Generated by OpenCVE AI on October 29, 2026 at 16:11 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 14:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 29 Oct 2026 13:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CozyThemes Cozy Blocks cozy-addons allows Stored XSS.This issue affects Cozy Blocks: from n/a through 2.2.27.
Title WordPress Cozy Blocks plugin <= 2.2.27 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-29T13:47:36.226Z

Reserved: 2026-01-23T12:31:40.820Z

Link: CVE-2026-24533

cve-icon Vulnrichment

Updated: 2026-10-29T13:45:34.255Z

cve-icon NVD

Status : Deferred

Published: 2026-10-29T13:17:10.587

Modified: 2026-10-29T14:56:26.107

Link: CVE-2026-24533

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T16:15:04Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')