Description
Missing Authorization vulnerability in weDevs WP ERP erp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP ERP: from n/a through 1.17.10.
Published: 2026-10-29
Score: 4.3 Medium
EPSS: n/a
KEV: No
Impact: Broken Access Control
Action: Patch
AI Analysis

Impact

The vulnerability stems from missing authorization checks in the weDevs WP ERP plugin, classified as CWE-862. These gaps allow users with insufficient privileges to access privileged administrative functions, leading to potential alteration or disclosure of sensitive business data. Based on the description, it is inferred that an attacker could exploit the plugin’s exposed endpoints either through a normal user session or, if any endpoint is public, via unauthenticated requests.

Affected Systems

WordPress installations running the weDevs WP ERP plugin version 1.17.10 or earlier are affected. The flaw applies to all sites where the plugin is present and configured as described, regardless of other security controls.

Risk and Exploitability

The CVSS score of 4.3 indicates a moderate risk level. EPSS is not available, so the probability of exploitation is uncertain, and the vulnerability is not listed in CISA’s KEV catalog, suggesting no confirmed large-scale attacks. Nonetheless, because the flaw permits unauthorized access to administrative capabilities, it poses a moderate threat, especially in environments with weak user role restrictions or default credentials. An attacker would need access to the WordPress site, either through an existing account or by compromising a user session.

Generated by OpenCVE AI on October 29, 2026 at 18:01 UTC.

Remediation

Vendor Solution

Update the WordPress WP ERP plugin to the latest available version (at least 1.17.11).


OpenCVE Recommended Actions

  • Update the WordPress WP ERP plugin to version 1.17.11 or later to apply the vendor‑provided authorization fix.
  • Verify and configure WordPress user roles so that only administrators can access critical plugin features, ensuring strict enforcement of access levels.
  • If the plugin is not essential, consider disabling or uninstalling it and monitor any custom code that interacts with the plugin to prevent accidental exposure of administrative functions.

Generated by OpenCVE AI on October 29, 2026 at 18:01 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 15:00:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in weDevs WP ERP erp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP ERP: from n/a through 1.17.10.
Title WordPress WP ERP plugin <= 1.17.10 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 4.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-29T14:55:02.968Z

Reserved: 2026-02-02T12:53:47.193Z

Link: CVE-2026-25448

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-29T15:17:22.147

Modified: 2026-10-29T15:18:54.943

Link: CVE-2026-25448

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T18:15:14Z

Weaknesses