Description
The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.
Published: 2026-10-28
Score: 5.3 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Unauthorized Data Exposure to unauthenticated users
Action: Immediate Patch
AI Analysis

Impact

The Advanced Custom Fields: Extended plugin for WordPress suffers from missing authorization checks on multiple AJAX handlers. The handlers are accessible to unauthenticated users and use a cryptographic nonce that is generated for guest users and embedded in the page source. An attacker can extract this nonce and bypass WordPress visibility permissions, resulting in the unauthorized disclosure of post titles and the internal layout structures of Flexible Content fields.

Affected Systems

All installations of Advanced Custom Fields: Extended up to and including version 0.9.2.7. The plugin is distributed by hwk-fr and is widely used in WordPress environments. Versions 0.9.2.4 and later contain a partial patch, while the vulnerability remains in all earlier releases.

Risk and Exploitability

The vulnerability carries a CVSS score of 5.3, indicating moderate severity, and no EPSS data is available. It is not listed in CISA’s KEV catalog. Attackers need only a public-facing form that uses the plugin to retrieve the guest nonce; no additional credentials or privileges are required. Once the nonce is obtained, the affected AJAX endpoints can return protected content, exposing sensitive information to unauthenticated users.

Generated by OpenCVE AI on October 28, 2026 at 08:37 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Advanced Custom Fields: Extended plugin to the latest version that addresses the authorization flaw.
  • Ensure that all AJAX endpoints of the plugin are protected with proper authentication checks; if the plugin does not provide them, disable or restrict the endpoints on public pages.
  • Remove or obfuscate the public disclosure of guest nonces by limiting form rendering to authenticated users or by implementing custom nonce generation that requires user authentication.

Generated by OpenCVE AI on October 28, 2026 at 08:37 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.
Title Advanced Custom Fields: Extended <= 0.9.2.7 - Missing Authorization to Unauthenticated Data Exposure via Multiple AJAX Endpoints
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 5.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:17.566Z

Reserved: 2026-02-19T22:46:25.318Z

Link: CVE-2026-2839

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-28T07:16:48.367

Modified: 2026-10-28T13:46:33.207

Link: CVE-2026-2839

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T08:45:14Z

Weaknesses