Description
Unauthenticated Cross Site Scripting (XSS) in Progressify - Progressive Web App (PWA) <= 1.6.0 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is an unauthenticated cross site scripting flaw that allows an attacker to inject arbitrary script code into web pages served by the Progressify plugin. Because the flaw is present in all unauthenticated users who load the vulnerable pages, an attacker can run malicious JavaScript in the context of the site, which can lead to theft of user credentials, session hijacking, defacement, or the delivery of further malware. The weakness is identified as CWE-79.

Affected Systems

DaftPlug’s Progressify – Progressive Web App plugin deployed on WordPress installations, specifically versions 1.6.0 and earlier. No other vendors or products are listed as affected.

Risk and Exploitability

The CVSS score of 7.1 indicates a medium to high severity vulnerability. The EPSS score of <1% indicates a very low probability of exploitation, though the plugin’s widespread use may increase overall exposure. The vulnerability is not listed in the CISA KEV catalog at this time. Based on the description, the likely attack vector is via a crafted URL or content input that triggers the XSS without requiring authentication.

Generated by OpenCVE AI on October 7, 2026 at 06:35 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Progressify plugin to the latest available version (1.6.1 or newer).
  • If an upgrade is not immediately possible, disable or remove the plugin from the WordPress installation to eliminate the attack surface.
  • Verify that all other WordPress plugins and the core platform are up to date, and apply additional security hardening such as content security policy headers to mitigate potential residual XSS risks.

Generated by OpenCVE AI on October 7, 2026 at 06:35 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in Progressify - Progressive Web App (PWA) <= 1.6.0 versions.
Title WordPress Progressify - Progressive Web App (PWA) plugin <= 1.6.0 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:42.083Z

Reserved: 2026-03-12T11:12:52.970Z

Link: CVE-2026-32570

cve-icon Vulnrichment

Updated: 2026-10-06T10:31:16.738Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:42.550

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-32570

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T06:45:13Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')