Description
Unauthenticated Cross Site Scripting (XSS) in WP User Frontend Pro <= 4.2.13 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross Site Scripting
Action: Apply Patch
AI Analysis

Impact

An unauthenticated Cross Site Scripting flaw exists in WP User Frontend Pro versions up to 4.2.13. The vulnerability allows an attacker to inject arbitrary JavaScript that is rendered in the browser of any user who views affected content. Because no authentication is required, the flaw can be exploited by anyone visiting the site, enabling phishing, cookie theft, or defacement. The weakness is a classic input‑validation error (CWE‑79).

Affected Systems

The vulnerable software is the weDevs WP User Frontend Pro plugin for WordPress, specifically versions 4.2.13 and earlier. Sites that have installed these plugin releases with the plugin’s form or front‑end input fields exposed are susceptible.

Risk and Exploitability

The CVSS score of 7.1 indicates a high severity. The EPSS score is < 1%, indicating a very low exploitation probability. The lack of a KEV listing does not diminish the potential risk. The likely attack vector is via the plugin’s input fields; because authentication is not required, any visitor to a page that processes the plugin data can deliver malicious script. Successful exploitation results in the execution of attacker‑supplied code within the victim’s browser session, compromising confidentiality, integrity, and availability of the user’s data and site content.

Generated by OpenCVE AI on October 7, 2026 at 05:48 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade WP User Frontend Pro to version 4.2.14 or later to apply the vendor’s fix.
  • If an immediate upgrade is not feasible, temporarily deactivate or remove the plugin to eliminate the vulnerable surfaces.
  • Implement a web application firewall or input sanitization rule that blocks malicious script content in the plugin’s form fields until a patch is applied.

Generated by OpenCVE AI on October 7, 2026 at 05:48 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in WP User Frontend Pro <= 4.2.13 versions.
Title WordPress WP User Frontend Pro plugin <= 4.2.13 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:41.804Z

Reserved: 2026-03-12T11:12:52.970Z

Link: CVE-2026-32572

cve-icon Vulnrichment

Updated: 2026-10-06T10:31:14.052Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:42.847

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-32572

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T06:00:08Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')