Description
Unauthenticated Cross Site Scripting (XSS) in Mapster WP Maps <= 2.0.4 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross Site Scripting (XSS)
Action: Immediate Patch
AI Analysis

Impact

An unauthenticated Cross Site Scripting (XSS) vulnerability exists in versions of the Mapster WP Maps WordPress plugin 2.0.4 and earlier. The flaw results from improper handling of user-supplied input, allowing the injection of arbitrary JavaScript that will be executed in the browser when a page containing a vulnerable map is viewed. Successful exploitation can lead to defacement, cookie theft, or further malware delivery, compromising the confidentiality, integrity, and availability of the site.

Affected Systems

The affected vendor is Mapster, and the product is the Mapster WP Maps plugin for WordPress. Any installation running the plugin version 2.0.4 or any earlier minor release is vulnerable. The issue was addressed in version 2.0.5; installing that or later versions removes the flaw.

Risk and Exploitability

The CVSS base score of 7.1 indicates moderate severity, and the EPSS score of <1% indicates an extremely low likelihood of exploitation. No KEV listing is available, suggesting no publicly known exploitation campaigns. Because the vulnerability is client‑side and unauthenticated, an attacker can craft a malicious payload without credentials, typically by injecting script into the map shortcode or via a public URL. The low barrier to exploitation combined with the popularity of WordPress means this vulnerability is a high‑priority patch issue.

Generated by OpenCVE AI on October 7, 2026 at 05:46 UTC.

Remediation

Vendor Solution

Update the WordPress Mapster WP Maps plugin to the latest available version (at least 2.0.5).


OpenCVE Recommended Actions

  • Update the Mapster WP Maps plugin to version 2.0.5 or newer.
  • If an immediate update is not feasible, temporarily disable the plugin or remove its shortcodes from public pages until the patch is applied.
  • Restrict map‑related shortcode usage to authenticated administrators so that only trusted users can embed potentially vulnerable content.

Generated by OpenCVE AI on October 7, 2026 at 05:46 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in Mapster WP Maps <= 2.0.4 versions.
Title WordPress Mapster WP Maps plugin <= 2.0.4 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:40.515Z

Reserved: 2026-04-07T10:58:29.177Z

Link: CVE-2026-39720

cve-icon Vulnrichment

Updated: 2026-10-06T10:30:49.187Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:44.227

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-39720

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T06:00:08Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')