Description
Unauthenticated Cross Site Scripting (XSS) in HTTP Requests Manager <= 1.3.11 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross‑Site Scripting
Action: Patch
AI Analysis

Impact

The flaw is an unauthenticated Cross‑Site Scripting (XSS) vulnerability that allows an attacker to inject malicious script code into the HTTP Requests Manager plugin for WordPress. Because the application does not properly validate or encode user input, the injected code can execute within the web browser of any visitor who views the affected page or content. This vulnerability can lead to theft of session cookies, defacement, or other client‑side attacks against site users.

Affected Systems

The vulnerability affects all installations of the HTTP Requests Manager plugin by veppa that are at version 1.3.11 or earlier. Users running WordPress with this plugin should verify their version and determine whether an upgrade is available.

Risk and Exploitability

With a CVSS score of 7.1, the vulnerability is classified as high severity, and its EPSS score is 0.237%. The attack is likely to be performed by sending crafted requests to the vulnerable plugin endpoint, which does not require authentication. The vulnerability is not listed in the CISA Known Exploited Vulnerabilities catalog, but the potential impact on site users warrants immediate remediation.

Generated by OpenCVE AI on October 7, 2026 at 06:14 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the latest update for the HTTP Requests Manager plugin to eliminate the XSS vector.
  • Implement input validation and output encoding on any user-supplied data that interacts with the plugin’s interface.
  • If an update is not immediately possible, consider removing or disabling the plugin until a patch is applied, and monitor activity for potential injection attempts.

Generated by OpenCVE AI on October 7, 2026 at 06:14 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in HTTP Requests Manager <= 1.3.11 versions.
Title WordPress HTTP Requests Manager plugin <= 1.3.11 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:40.239Z

Reserved: 2026-04-07T10:58:34.148Z

Link: CVE-2026-39724

cve-icon Vulnrichment

Updated: 2026-10-06T10:30:45.903Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:44.533

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-39724

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T06:15:12Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')