Description
Unauthenticated Cross Site Scripting (XSS) in Midtrans-WooCommerce <= 2.32.3 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Unauthenticated Cross Site Scripting (XSS)
Action: Patch
AI Analysis

Impact

An unauthenticated cross‑site scripting flaw exists in the Midtrans‑WooCommerce WordPress plugin up through version 2.32.3. The plugin reflects user‑supplied data onto pages without proper sanitization, allowing an attacker to inject and execute malicious JavaScript in the browsers of visitors who view those pages. Because the attack does not require authentication, any user who visits a vulnerable site can trigger the flaw. The injected script runs with the privileges of the visitor’s browser session, potentially enabling actions that the site intended to be safe for. The likely impact includes compromise of data confidentiality and integrity for users, and a degradation of the site's overall usability. The vulnerability carries a CVSS score of 7.1, indicating a high level of risk. The EPSS score of <1% indicates a low probability of exploitation, while it is not listed in the CISA KEV catalog, but the potential for exploitation remains.

Affected Systems

WordPress sites installed with the Midtrans‑WooCommerce plugin version 2.32.3 or earlier are affected. This includes any WordPress installation that still uses that version or earlier without upgrading the plugin.

Risk and Exploitability

The flaw is publicly exploitable because no authentication is required. Attackers can simply embed malicious scripts in content rendered by the plugin, causing code execution in the victim’s browser. With a CVSS score of 7.1 the vulnerability is considered high risk, and the EPSS score of <1% indicates a low probability of exploitation, while it is not listed in the CISA KEV catalog, but the potential for exploitation remains.

Generated by OpenCVE AI on October 7, 2026 at 05:25 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Midtrans‑WooCommerce plugin to a supported release version (≥2.32.4).
  • If an immediate upgrade is not possible, configure the web server or CMS to strip or encode any output generated by the plugin before sending it to the browser.
  • Add a content‑security‑policy header that restricts inline script execution and limits script sources to trusted domains.

Generated by OpenCVE AI on October 7, 2026 at 05:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 22:00:00 +0000

Type Values Removed Values Added
First Time appeared Midtrans
Midtrans midtrans-woocommerce
Wordpress-extensions
Wordpress-extensions midtrans-woocommerce
Vendors & Products Midtrans
Midtrans midtrans-woocommerce
Wordpress-extensions
Wordpress-extensions midtrans-woocommerce

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in Midtrans-WooCommerce <= 2.32.3 versions.
Title WordPress Midtrans-WooCommerce plugin <= 2.32.3 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Midtrans Midtrans-woocommerce
Wordpress-extensions Midtrans-woocommerce
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:37.448Z

Reserved: 2026-04-07T10:58:58.454Z

Link: CVE-2026-39758

cve-icon Vulnrichment

Updated: 2026-10-06T10:30:09.664Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:47.707

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-39758

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T05:30:13Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')