Description
Editor Remote Code Execution (RCE) in Tabs <= 2.5 versions.
Published: 2026-10-06
Score: 8 High
EPSS: < 1% Very Low
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is an Editor Remote Code Execution flaw found in the WordPress Tabs plugin versions 2.5 and earlier. It allows an attacker who can interact with the plugin’s editor interface to inject arbitrary code that is executed on the server with the web‑server’s privileges. This flaw is a classic code‑injection weakness (CWE‑94) and results in complete compromise of confidentiality, integrity and availability of the affected WordPress site.

Affected Systems

The flaw affects the wpshopmart Tabs plugin for WordPress, versions 2.5 and prior. Any WordPress installation that has the plugin installed and has not applied the vendor’s corrective update is vulnerable. The description does not list further prerequisites, but an attacker needs authenticated access to the plugin editor.

Risk and Exploitability

The vulnerability carries a CVSS score of 8, indicating high severity. The EPSS score is 0.00384 (0.384%) and the issue is not yet listed in the CISA KEV catalog. The likely attack vector is remote; an attacker could exploit the editor interface if it is accessible to privileged users or, if misconfigured, to lesser users. Given the high severity and the potential for arbitrary code execution, site administrators should treat this as an urgent threat.

Generated by OpenCVE AI on October 7, 2026 at 05:44 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Tabs plugin to a version newer than 2.5 as released by wpshopmart.
  • If an update cannot be applied immediately, disable or uninstall the Tabs plugin to eliminate the vulnerable editor component.
  • Restrict editor access so that only trusted administrators can use it, and as a temporary measure “sanitize” or review any content that is submitted through the editor to remove executable code.

Generated by OpenCVE AI on October 7, 2026 at 05:44 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 22:00:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions tabs
Wpshopmart
Wpshopmart tabs
Vendors & Products Wordpress-extensions
Wordpress-extensions tabs
Wpshopmart
Wpshopmart tabs

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Editor Remote Code Execution (RCE) in Tabs <= 2.5 versions.
Title WordPress Tabs plugin <= 2.5 - Remote Code Execution (RCE) vulnerability
Weaknesses CWE-94
References
Metrics cvssV3_1

{'score': 8, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H'}


Subscriptions

Wordpress-extensions Tabs
Wpshopmart Tabs
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:35.164Z

Reserved: 2026-04-07T10:59:10.175Z

Link: CVE-2026-39776

cve-icon Vulnrichment

Updated: 2026-10-06T10:29:39.519Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:50.347

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-39776

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T05:45:13Z

Weaknesses
  • CWE-94

    Improper Control of Generation of Code ('Code Injection')