Description
Subscriber Cross Site Scripting (XSS) in Front End PM <= 11.4.6 versions.
Published: 2026-10-06
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Cross‑Site Scripting
Action: Patch Upgrade
AI Analysis

Impact

This flaw in the Front End PM plugin allows a subscriber to embed arbitrary script code within the plugin’s interface. The injected code could execute in a visitor’s browser, enabling defacement, credential theft, or session hijacking. The vulnerability is a classic example of unsanitized user input leading to arbitrary script execution, corresponding to CWE‑79.

Affected Systems

WordPress sites using the Front End PM plugin version 11.4.6 or earlier, developed by Shamim Hasan.

Risk and Exploitability

The moderate CVSS score of 6.5 suggests that the vulnerability requires the attacker to be an authenticated subscriber, though this is inferred from the described context rather than explicitly stated, and grants significant impact on the target site. The EPSS score of < 1% indicates a very low probability of exploitation, and the vulnerability is not listed in CISA's KEV catalog. The attack vector is likely through the plugin’s subscriber‑level endpoints and does not require additional system’s functionality.

Generated by OpenCVE AI on October 7, 2026 at 05:11 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Front End PM plugin to a version newer than 11.4.6 to remove the vulnerable code paths.
  • If an upgrade is not feasible immediately, restrict subscriber permissions to eliminate any form or input fields that can be used to inject scripts, or disable the Front End PM functionality entirely until patched.
  • Implement or strengthen a content‑security‑policy to block execution of unexpected script sources, which can mitigate the impact of any remaining XSS vectors.

Generated by OpenCVE AI on October 7, 2026 at 05:11 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 22:00:00 +0000

Type Values Removed Values Added
First Time appeared Shamimsplugins
Shamimsplugins front End Pm
Wordpress-extensions
Wordpress-extensions front End Pm
Vendors & Products Shamimsplugins
Shamimsplugins front End Pm
Wordpress-extensions
Wordpress-extensions front End Pm

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Subscriber Cross Site Scripting (XSS) in Front End PM <= 11.4.6 versions.
Title WordPress Front End PM plugin <= 11.4.6 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Shamimsplugins Front End Pm
Wordpress-extensions Front End Pm
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:34.162Z

Reserved: 2026-04-07T10:59:15.736Z

Link: CVE-2026-39788

cve-icon Vulnrichment

Updated: 2026-10-06T10:29:27.912Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:51.627

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-39788

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T05:15:12Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')