Description
Unauthenticated Cross Site Scripting (XSS) in WooCommerce Simple Auctions <= 3.0.10 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Client‑Side Script Execution via XSS
Action: Apply Patch
AI Analysis

Impact

Unauthenticated Cross‑Site Scripting (XSS) is present in WooCommerce Simple Auctions plugin versions up to 3.0.10. An attacker can inject arbitrary JavaScript that will execute in the browsers of visitors who view affected auction pages. This weakness allows the attacker to steal session cookies, deface the site, or redirect users as described in the CVE description. The vulnerability is a classic input‑validation issue classified as CWE‑79.

Affected Systems

The affected system is the WordPress plugin WooCommerce Simple Auctions delivered by wpgenie. All releases of the plugin with a version number of 3.0.10 or older are vulnerable. Users running those versions on public‑facing WordPress sites are at risk.

Risk and Exploitability

The CVSS score of 7.1 places this flaw in the high severity range. The EPSS score of 0.00251 indicates a very low probability of exploitation, but the flaw could still be used in targeted attacks. The vulnerability is not currently listed in the CISA KEV catalog. The likely attack vector is unauthenticated interaction with the site, such as visiting a malicious auction URL or submitting a crafted form; the attacker does not need prior authorization or privileged access to exploit it.

Generated by OpenCVE AI on October 7, 2026 at 05:19 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade WooCommerce Simple Auctions to a version newer than 3.0.10 that contains the XSS fix.
  • If an immediate upgrade is not feasible, restrict the plugin’s output by sanitizing or removing user‑supplied content from auction titles and descriptions, or temporarily disable the plugin on the site until a patch is available.
  • Apply site‑wide XSS protections: enable output escaping for WooCommerce templates, use a web application firewall that blocks script payloads, and configure browser security headers such as X‑Content‑Type‑Options, X‑XSS‑Protection, and a strong Content‑Security‑Policy.

Generated by OpenCVE AI on October 7, 2026 at 05:19 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 21:15:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions woocommerce Simple Auctions
Wpgenie
Wpgenie woocommerce Simple Auctions
Vendors & Products Wordpress-extensions
Wordpress-extensions woocommerce Simple Auctions
Wpgenie
Wpgenie woocommerce Simple Auctions

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in WooCommerce Simple Auctions <= 3.0.10 versions.
Title WordPress WooCommerce Simple Auctions plugin <= 3.0.10 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Wordpress-extensions Woocommerce Simple Auctions
Wpgenie Woocommerce Simple Auctions
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:30.527Z

Reserved: 2026-04-29T07:06:45.122Z

Link: CVE-2026-42635

cve-icon Vulnrichment

Updated: 2026-10-06T10:28:46.519Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:55.193

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-42635

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T05:30:13Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')