Description
Unauthenticated Cross Site Scripting (XSS) in WP Crowdfunding <= 2.2.2 versions.
Published: 2026-10-29
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Cross Site Scripting
Action: Immediate Patch
AI Analysis

Impact

An unauthenticated Cross Site Scripting flaw exists in WordPress WP Crowdfunding plugin versions 2.2.2 and earlier, which allows an attacker to inject arbitrary JavaScript into the page. The vulnerability arises from unsanitized user input being reflected or stored, enabling malicious scripts to run in the context of site visitors. This can lead to defacement, theft of user credentials, session hijacking, or the execution of additional malicious payloads. The weakness is a classic reflective XSS identified as CWE-79.

Affected Systems

The flaw affects WordPress installations that include the Themeum WP Crowdfunding plugin version 2.2.2 or older. Any site running these versions, regardless of the user role, is vulnerable because the injection point does not require authentication or elevated privileges. Administrators, editors, and anonymous visitors could all trigger the payload once the script is embedded.

Risk and Exploitability

The vulnerability carries a CVSS score of 7.1, indicating moderate to high severity. Although an EPSS score is not available, the lack of a CISA KEV listing and the public disclosure suggest that exploitation is plausible but not determined to be actively targeted at this time. Attackers would likely issue a crafted HTTP request to the plugin’s endpoint to inject the script, taking advantage of the unauthenticated nature of the flaw and the absence of input validation controls.

Generated by OpenCVE AI on October 29, 2026 at 17:08 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the WP Crowdfunding plugin to the latest release, which eliminates the unsanitized input handling.
  • If an upgrade is not immediately possible, remove or deactivate the plugin and replace it with an alternative that has validated input handling.
  • Implement content security policy headers and enable the browser’s built‑in XSS filters to provide an additional layer of protection against injected scripts.

Generated by OpenCVE AI on October 29, 2026 at 17:08 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in WP Crowdfunding <= 2.2.2 versions.
Title WordPress WP Crowdfunding plugin <= 2.2.2 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-29T15:23:59.420Z

Reserved: 2026-04-29T09:05:01.790Z

Link: CVE-2026-42692

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-29T16:18:09.130

Modified: 2026-10-29T16:20:19.663

Link: CVE-2026-42692

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T17:15:07Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')