Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in FolioVision FV Flowplayer Video Player fv-wordpress-flowplayer allows Stored XSS.This issue affects FV Flowplayer Video Player: from n/a through 7.5.54.7212.
Published: 2026-10-09
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Immediate Patch
AI Analysis

Impact

FolioVision FV Flowplayer Video Player contains improper neutralization of user input during web page generation, allowing stored malicious scripts to persist in the plugin’s database. Executed by any visitor to the affected WordPress site, the injected code can hijack sessions, redirect users, or steal sensitive data. The weakness is a classic stored XSS flaw that undermines web application integrity and can compromise users interacting with the vulnerable content.

Affected Systems

The vulnerability exists in WordPress sites that use the FolioVision FV Flowplayer Video Player plugin through any version up to 7.5.54.7212. All installations relying on this plugin, regardless of WordPress theme or configuration, are affected.

Risk and Exploitability

With a CVSS score of 6.5 the issue is rated moderate severity. EPSS data is unavailable and the vulnerability is not listed in CISA’s KEV catalog, suggesting no widespread exploitation at present. Based on the description the attack vector is through ingestion of user‑supplied content that the plugin stores and later renders, allowing an attacker to embed scripts that are served to any user who views that content. The scenario requires the attacker to inject malicious code into the plugin’s stored fields, either via an administrative interface or through any input that the plugin accepts and displays.

Generated by OpenCVE AI on October 9, 2026 at 18:54 UTC.

Remediation

Vendor Solution

Update the WordPress FV Flowplayer Video Player plugin to the latest available version (at least 7.5.55.7212).


OpenCVE Recommended Actions

  • Update FV Flowplayer Video Player to version 7.5.55.7212 or later.
  • If the plugin cannot be updated immediately, temporarily deactivate it on all public‑facing pages that display video content until the patch is applied.
  • Configure a Content Security Policy that restricts script execution to trusted sources to mitigate the impact of any remaining XSS payloads.

Generated by OpenCVE AI on October 9, 2026 at 18:54 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 09 Oct 2026 17:00:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in FolioVision FV Flowplayer Video Player fv-wordpress-flowplayer allows Stored XSS.This issue affects FV Flowplayer Video Player: from n/a through 7.5.54.7212.
Title WordPress FV Flowplayer Video Player plugin <= 7.5.54.7212 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-11T11:42:55.084Z

Reserved: 2026-04-29T09:05:01.790Z

Link: CVE-2026-42695

cve-icon Vulnrichment

Updated: 2026-10-11T11:35:10.123Z

cve-icon NVD

Status : Deferred

Published: 2026-10-09T17:16:47.333

Modified: 2026-10-11T12:16:55.670

Link: CVE-2026-42695

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T19:00:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')