Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GhozyLab Image Slider Widget image-slider-widget allows Stored XSS.This issue affects Image Slider Widget: from n/a through 1.1.130.
Published: 2026-10-05
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch
AI Analysis

Impact

The vulnerability is a stored cross‑site scripting flaw that allows an attacker to inject arbitrary JavaScript which is executed within the context of the visitor's browser. This flaw can directly lead to credential theft, redirection, or defacement of the website, compromising confidentiality, integrity, and availability for any user who visits a page that renders the malicious content. The weakness is an input validation failure (CWE‑79) in the Image Slider Widget plugin.

Affected Systems

The plugin GhozyLab Image Slider Widget, version 1.1.130 and all earlier releases, is affected. If the plugin is installed on a WordPress site, any content input that is stored by the widget and later displayed can be used to deliver malicious scripts.

Risk and Exploitability

The CVSS base score of 6.5 indicates significant risk, and although an EPSS score is unavailable, the absence of exploitation probability data does not mitigate the severity of a stored XSS. The vulnerability is not listed in the CISA KEV catalog, but once a public exploit emerges, it could become a high‑impact threat. The likely attack vector involves submitting malicious code as part of the widget configuration or content, which is stored and later rendered in a user‑visible page.

Generated by OpenCVE AI on October 5, 2026 at 18:36 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Image Slider Widget to a version newer than 1.1.130, or apply the official vendor patch if available.
  • If an upgrade is not immediately possible, remove or disable the Image Slider Widget on public or untrusted pages until patching is performed.
  • Verify that any user‑supplied data used by the widget is properly escaped or sanitized to mitigate similar XSS risks in future plugin versions.

Generated by OpenCVE AI on October 5, 2026 at 18:36 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 05 Oct 2026 18:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 05 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GhozyLab Image Slider Widget image-slider-widget allows Stored XSS.This issue affects Image Slider Widget: from n/a through 1.1.130.
Title WordPress Image Slider Widget plugin <= 1.1.130 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-05T17:44:52.388Z

Reserved: 2026-04-29T09:05:07.700Z

Link: CVE-2026-42700

cve-icon Vulnrichment

Updated: 2026-10-05T17:44:48.600Z

cve-icon NVD

Status : Deferred

Published: 2026-10-05T18:17:36.940

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-42700

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-05T18:45:19Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')