Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins PDF Poster pdf-poster allows Stored XSS.This issue affects PDF Poster: from n/a through 2.6.1.
Published: 2026-10-29
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Patch
AI Analysis

Impact

The PDF Poster plugin for WordPress stores unsanitized user input, allowing an attacker to embed malicious JavaScript that is later rendered in browsers. This stored XSS flaw can compromise the confidentiality, integrity, and availability of the site by executing code in the context of any visitor who accesses the affected content. Based on the description, it is inferred that attackers would likely need to inject malicious payloads through the plugin’s data entry mechanisms, which may require authenticated access or the ability to influence stored content.

Affected Systems

The issue exists in all releases of bPlugins PDF Poster from the earliest version through 2.6.1. Upgrading to at least version 2.6.2 eliminates the vulnerability.

Risk and Exploitability

The CVSS score of 6.5 indicates moderate severity, and the EPSS score is not available, suggesting limited public exploitation data. The flaw is not listed in CISA’s KEV catalog. Once the attacker injects malicious input via the plugin, the script runs with the privileges of any visitor to the site, making the vulnerability moderate in exploitability but still significant for exposed users.

Generated by OpenCVE AI on October 29, 2026 at 16:47 UTC.

Remediation

Vendor Solution

Update the WordPress PDF Poster plugin to the latest available version (at least 2.6.2).


OpenCVE Recommended Actions

  • Update the PDF Poster plugin to version 2.6.2 or later.
  • Restrict access to the plugin’s data entry interfaces to trusted administrators only, or disable the plugin on publicly accessible sections.
  • Deploy a web application firewall rule that blocks or sanitizes suspicious input patterns to reduce the risk of XSS exploitation.

Generated by OpenCVE AI on October 29, 2026 at 16:47 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 14:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 29 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins PDF Poster pdf-poster allows Stored XSS.This issue affects PDF Poster: from n/a through 2.6.1.
Title WordPress PDF Poster plugin <= 2.6.1 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-29T13:47:35.412Z

Reserved: 2026-05-21T08:53:20.444Z

Link: CVE-2026-48195

cve-icon Vulnrichment

Updated: 2026-10-29T13:45:19.883Z

cve-icon NVD

Status : Deferred

Published: 2026-10-29T14:17:55.793

Modified: 2026-10-29T14:56:26.107

Link: CVE-2026-48195

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T17:00:15Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')