Description
Unauthenticated Cross Site Scripting (XSS) in Post Video Players <= 1.165 versions.
Published: 2026-10-29
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Cross‑Site Scripting (XSS) affecting all site visitors
Action: Update plugin
AI Analysis

Impact

The vulnerability is an unauthenticated Cross‑Site Scripting flaw in the Post Video Players plugin versions 1.165 and earlier. A malicious actor can inject arbitrary JavaScript that executes in the context of any user who views a page that renders the affected plugin's output. This allows attackers to steal session cookies, deface content, or launch further payloads. The flaw originates from insufficient input sanitization in the plugin’s handling of video metadata or other user‑supplied fields. No additional exploitation prerequisites are listed.

Affected Systems

The issue affects WordPress installations running the nicashmu Post Video Players plugin at version 1.165 or earlier. Users who have not upgraded beyond 1.165 are exposed. The plugin is a third‑party media‑display component commonly used to embed video galleries.

Risk and Exploitability

The CVSS base score of 7.1 reflects a moderate‑to‑high impact for unauthenticated users. The EPSS score is missing, so the likelihood cannot be quantified, but XSS vulnerabilities typically have predictable exploitation. The vulnerability is not listed in the CISA KEV catalog, suggesting no confirmed large‑scale attacks yet. The attack vector is inferred to be unauthenticated through web input fields, as the flaw is described as unauthenticated. Until a patch is applied, any user who interacts with a page rendering the plugin may be affected.

Generated by OpenCVE AI on October 29, 2026 at 17:05 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Post Video Players plugin to the latest version (at least 1.166) from the official WordPress repository or the plugin vendor’s site, ensuring the fix for the XSS issue is applied.
  • If the plugin is not essential to site functionality, remove or disable it entirely to eliminate the vulnerability surface.
  • Review any custom video entries or metadata that might be displayed by the plugin and apply manual input validation or sanitization to any user‑supplied fields until a patched version is installed.

Generated by OpenCVE AI on October 29, 2026 at 17:05 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in Post Video Players <= 1.165 versions.
Title WordPress Post Video Players plugin <= 1.165 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-29T15:24:04.940Z

Reserved: 2026-06-16T09:22:12.122Z

Link: CVE-2026-54864

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-29T16:18:10.333

Modified: 2026-10-29T16:20:19.663

Link: CVE-2026-54864

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T17:15:07Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')