Description
Subscriber Cross Site Scripting (XSS) in Podamibe Custom User Gravatar <= 1.0.8 versions.
Published: 2026-10-29
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Cross Site Scripting (XSS)
Action: Apply Patch
AI Analysis

Impact

Podamibe Custom User Gravatar is a WordPress plugin that enables site administrators to display custom avatar images for users. The vulnerability allows a malicious actor to inject arbitrary HTML or JavaScript code that is rendered in the browsers of anyone who views the affected site. By exploiting this flaw an attacker can steal session cookies, deface the site, or redirect users to phishing pages. This is a classic reflected XSS flaw caused by insufficient input sanitization when outputting user‑supplied avatar data.

Affected Systems

The flaw exists in all installations of Podamibe Custom User Gravatar version 1.0.8 or earlier on WordPress websites. Any site that has this plugin ready to accept avatar or user profile data from subscribers is vulnerable; the issue is tied to the plugin, not the core WordPress installation itself.

Risk and Exploitability

The CVSS score of 6.5 indicates a moderate severity. No EPSS score is available, and the vulnerability is not listed in CISA KEV, suggesting that exploit activity has not been reported to date. The inferred attack vector is that a subscriber or user who can add or edit their avatar data can inject malicious scripts that are then reflected when the site renders the avatar. Once an attacker succeeds, the stolen data is local to the visitor’s browser, but the impact on confidentiality, integrity, and availability is potentially significant for the victim audience.

Generated by OpenCVE AI on October 29, 2026 at 17:05 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Podamibe Custom User Gravatar to the latest version (greater than 1.0.8) as released by the vendor.
  • If an upgrade is not immediately possible, disable or uninstall the plugin until a patched version is available.
  • Apply site‑wide security controls such as a web application firewall rule that blocks common XSS payloads in user profile fields.

Generated by OpenCVE AI on October 29, 2026 at 17:05 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Description Subscriber Cross Site Scripting (XSS) in Podamibe Custom User Gravatar <= 1.0.8 versions.
Title WordPress Podamibe Custom User Gravatar plugin <= 1.0.8 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-29T15:24:05.681Z

Reserved: 2026-06-16T09:22:12.122Z

Link: CVE-2026-54865

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-29T16:18:10.450

Modified: 2026-10-29T16:20:19.663

Link: CVE-2026-54865

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T17:15:07Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')