Description
The Windows installers of Apache OpenOffice 4.1.16 and earlier allow an already manipulated system to run external code with elevated access.
Users are recommended to upgrade to version 4.1.17, which fixes this issue.
Published: 2026-11-04
Score: n/a
EPSS: n/a
KEV: No
Impact: Remote Code Execution with elevated privileges
Action: Immediate Patch
AI Analysis

Impact

The vulnerability arises from an uncontrolled search path element in the Windows installers of Apache OpenOffice versions 4.1.16 and earlier. During installation, the installer searches for executable files in directories specified by environment variables, and because those directories are not properly sanitized, an attacker can cause the installer to launch an application of their choice. If the attacker can influence the installer environment, the selected external program runs with the same elevated privileges that the installer itself runs under, allowing arbitrary code execution with system rights. This flaw is CVE‑identified as a search‑path manipulation.

Affected Systems

Affected products are the Apache OpenOffice suite provided by the Apache Software Foundation. The issue applies to all Windows installers for OpenOffice 4.1.16 and earlier. The fix is available in version 4.1.17 and newer, which validates or neutralizes the search path during installation. No other product versions or operating systems are listed.

Risk and Exploitability

The risk assessment shows that the attacker must already have a manipulated system or control over the installer environment to exploit this flaw. Because the installers run with elevated privileges, a successful exploitation would allow full system compromise. No EPSS score is available, and the vulnerability is not listed in the KEV catalog, indicating no current evidence of widespread attacks. Nonetheless, the potential impact warrants immediate remediation through an upgrade or by restricting installer execution to trusted environments.

Generated by OpenCVE AI on November 4, 2026 at 12:41 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Apache OpenOffice to version 4.1.17 or later, which removes the uncontrolled search path flaw.
  • If an upgrade cannot be performed immediately, disable the ability of the installer to execute external programs by running the installer with the least privileges necessary and avoiding the use of environment variables that specify external paths.
  • Verify installer integrity using checksums or digital signatures before installation to ensure the executable has not been tampered with.
  • Limit installation to trusted, isolated machines or use virtualization/sandboxing to contain potential exploitation.

Generated by OpenCVE AI on November 4, 2026 at 12:41 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 04 Nov 2026 13:30:00 +0000

Type Values Removed Values Added
References

Wed, 04 Nov 2026 11:00:00 +0000

Type Values Removed Values Added
Description The Windows installers of Apache OpenOffice 4.1.16 and earlier allow an already manipulated system to run external code with elevated access. Users are recommended to upgrade to version 4.1.17, which fixes this issue.
Title Apache OpenOffice: Uncontrolled search path element vulnerability in Windows installer
Weaknesses CWE-427
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: apache

Published:

Updated: 2026-11-04T12:13:04.936Z

Reserved: 2026-07-04T15:34:24.392Z

Link: CVE-2026-59264

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-04T11:17:16.577

Modified: 2026-11-04T13:17:30.590

Link: CVE-2026-59264

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-04T12:45:14Z

Weaknesses
  • CWE-427

    Uncontrolled Search Path Element