Description
Missing Authorization vulnerability in RocketGeek WP-Members wp-members allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP-Members: from n/a through 3.5.7.
Published: 2026-10-12
Score: 5.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Unauthorized Access / Privilege Escalation
Action: Patch Immediately
AI Analysis

Impact

The WP‑Members plugin suffers from a broken access control flaw that allows an attacker to exploit incorrectly configured security levels, bypassing authorization checks and gaining unauthorized access to protected content or functions within a WordPress site. This weakness can let a malicious actor read, create, or modify content that should be restricted to certain user roles, potentially exposing sensitive data or enabling further exploitation.

Affected Systems

The vulnerability affects the WordPress WP‑Members plugin provided by RocketGeek, specifically all releases up through version 3.5.7. Any WordPress installation that has this plugin installed and is running a version at or below 3.5.7 is susceptible if its access control settings are not at the default secure configuration.

Risk and Exploitability

The CVSS score of 5.4 gives the flaw a moderate severity rating. Because the EPSS score is not available and the vulnerability is not listed in the CISA KEV catalog, the likelihood of widespread exploitation is unclear, but the potential impact to confidentiality and integrity is significant. The attack would typically involve making HTTP requests to the plugin’s endpoints from the browser or via automated scripts, relying on the fact that the plugin’s security levels have been misconfigured or left at a relaxed default. An attacker does not need elevated privileges beyond a standard user account to exploit the flaw, but the consequences can be far‑reaching when private content is exposed or administrative actions are performed.

Generated by OpenCVE AI on October 12, 2026 at 19:27 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade WordPress WP‑Members to the latest version (3.5.8 or newer) to apply the vendor’s access‑control fix.
  • Re‑evaluate and tighten the security level settings in the plugin’s configuration, ensuring that only authorized user roles can access restricted features.
  • If an immediate update is not possible, temporarily restrict access to the plugin’s front‑end and back‑end interfaces using WordPress role permissions or a firewall rule, and monitor site logs for suspicious access patterns.

Generated by OpenCVE AI on October 12, 2026 at 19:27 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 12 Oct 2026 23:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 12 Oct 2026 18:00:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in RocketGeek WP-Members wp-members allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP-Members: from n/a through 3.5.7.
Title WordPress WP-Members plugin <= 3.5.7 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-12T22:53:59.531Z

Reserved: 2026-07-13T06:14:05.180Z

Link: CVE-2026-61994

cve-icon Vulnrichment

Updated: 2026-10-12T22:52:28.857Z

cve-icon NVD

Status : Deferred

Published: 2026-10-12T18:17:23.183

Modified: 2026-10-13T13:28:15.717

Link: CVE-2026-61994

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-12T19:30:06Z

Weaknesses