Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Html5 Audio Player html5-audio-player allows Stored XSS.This issue affects Html5 Audio Player: from n/a through 2.8.8.
Published: 2026-10-09
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Cross-site scripting
Action: Apply patch
AI Analysis

Impact

The Html5 Audio Player plugin for WordPress contains an improper neutralization of input during web page generation, allowing an attacker to store malicious script code that executes when users view pages rendered by the plugin. This stored cross-site scripting can be used to steal session cookies, deface content, or perform other malicious actions within the scope of the vulnerable site. The weakness is a classic XSS flaw and is enumerated as CWE-79.

Affected Systems

Any WordPress installation that has installed the bPlugins Html5 Audio Player plugin version 2.8.8 or earlier is impacted. The vulnerability is present from the initial release up through version 2.8.8, covering all products listed under bPlugins:Html5 Audio Player.

Risk and Exploitability

The CVSS score of 6.5 indicates a medium risk level, while no EPSS score is currently available, so the likelihood of exploitation cannot be quantified beyond general XSS threats. The vulnerability is not listed in the CISA KEV catalog, but stored XSS is a well-known attack vector. The attack likely occurs when an authenticated user with the ability to create or edit plugin content injects malicious JavaScript, which is then rendered on pages for all visitors.

Generated by OpenCVE AI on October 9, 2026 at 13:37 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Html5 Audio Player plugin to a version newer than 2.8.8 as released by the vendor
  • If an upgrade cannot be performed immediately, configure the plugin or server to block script tags in content submitted to the plugin, effectively sanitizing user input
  • Consider disabling or removing the plugin from the WordPress site until a patched version is available

Generated by OpenCVE AI on October 9, 2026 at 13:37 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 09 Oct 2026 12:00:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Html5 Audio Player html5-audio-player allows Stored XSS.This issue affects Html5 Audio Player: from n/a through 2.8.8.
Title WordPress Html5 Audio Player plugin <= 2.8.8 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-11T11:42:55.643Z

Reserved: 2026-07-13T06:14:33.110Z

Link: CVE-2026-62039

cve-icon Vulnrichment

Updated: 2026-10-11T11:35:17.991Z

cve-icon NVD

Status : Deferred

Published: 2026-10-09T12:17:10.810

Modified: 2026-10-11T12:17:15.877

Link: CVE-2026-62039

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T13:45:06Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')