Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetBlocks For Elementor jet-blocks allows Stored XSS.This issue affects JetBlocks For Elementor: from n/a through 1.5.2.1.
Published: 2026-10-09
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch
AI Analysis

Impact

The flaw is an improper neutralization of user input during page generation, allowing a stored cross‑site scripting payload to be embedded by an authenticated user with editing privileges. When a legitimate visitor loads the affected page, the embedded script runs in the visitor's browser, potentially hijacking sessions, modifying page content, or exfiltrating data.

Affected Systems

Crocoblock JetBlocks For Elementor plugin versions up to and including 1.5.2.1 are affected. Any WordPress site that has this plugin installed at a vulnerable version is at risk.

Risk and Exploitability

The CVSS score of 6.5 indicates medium severity. No EPSS score is available, and the vulnerability is not listed in the CISA KEV catalog, suggesting no publicly known exploit yet. However, the stored XSS requires the attacker to have sufficient privileges to inject content through the plugin’s interface, after which all site visitors who view the compromised page are affected. This makes the risk significant enough to warrant immediate remediation.

Generated by OpenCVE AI on October 9, 2026 at 11:06 UTC.

Remediation

Vendor Solution

Update the WordPress JetBlocks For Elementor plugin to the latest available version (at least 1.5.2.2).


OpenCVE Recommended Actions

  • Update JetBlocks For Elementor to version 1.5.2.2 or later, which resolves the input sanitization issue.
  • If an update cannot be applied immediately, remove the JetBlocks For Elementor plugin from all WordPress sites until a patched version is available.
  • Ensure that any CMS user accounts are audited for unauthorized content insertion and that only trusted users have editing rights.
  • After applying the patch, verify that the plugin’s content fields no longer accept malicious scripts by attempting to inject a harmless script and confirming it is sanitized.

Generated by OpenCVE AI on October 9, 2026 at 11:06 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 10 Oct 2026 08:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 09 Oct 2026 09:30:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetBlocks For Elementor jet-blocks allows Stored XSS.This issue affects JetBlocks For Elementor: from n/a through 1.5.2.1.
Title WordPress JetBlocks For Elementor plugin <= 1.5.2.1 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-09T20:21:08.550Z

Reserved: 2026-07-13T06:14:38.874Z

Link: CVE-2026-62049

cve-icon Vulnrichment

Updated: 2026-10-09T20:21:05.579Z

cve-icon NVD

Status : Deferred

Published: 2026-10-09T10:16:38.067

Modified: 2026-10-09T21:17:05.353

Link: CVE-2026-62049

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T11:15:05Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')