Description
Unauthenticated Cross Site Scripting (XSS) in Barcode Scanner with Inventory & Order Manager <= 1.13.1 versions.
Published: 2026-10-10
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross Site Scripting
Action: Apply Patch
AI Analysis

Impact

an unauthenticated Cross Site Scripting flaw present in WordPress Barcode Scanner with Inventory & Order Manager plugin versions up to 1.13.1. The flaw enables an attacker to inject and execute arbitrary JavaScript within the context of any user who visits the affected plugin pages, potentially allowing session cookie theft, credential hijacking, defacement, or redirection to malicious sites. The weakness is identified as CWE‑79, reflecting insufficient validation or sanitization of untrusted input.

Affected Systems

The plugin author, Dmitry V., identified the affected product as the WordPress Barcode Scanner with Inventory & Order Manager plugin. Versions 1.13.1 and earlier of this plugin are vulnerable, so any WordPress installation running one of those releases is at risk.

Risk and Exploitability

The CVSS score of 7.1 classifies this flaw as High severity. EPSS data is not available and the vulnerability is not listed in CISA’s KEV catalog, indicating no confirmed exploitation reports yet. Nonetheless, the flaw is unauthenticated, meaning an attacker only needs to craft a malicious request or URL and persuade a user to access it. The impact can range from user‑level data theft to full site compromise if an administrator is affected. The lack of a known exploit does not reduce the threat, given the wide availability of the vulnerability and its severe potential consequences.

Generated by OpenCVE AI on October 10, 2026 at 21:52 UTC.

Remediation

Vendor Solution

Update the WordPress Barcode Scanner with Inventory & Order Manager plugin to the latest available version (at least 1.13.6).


OpenCVE Recommended Actions

  • Update the WordPress Barcode Scanner with Inventory & Order Manager plugin to version 1.13.6 or later, which fixes the XSS issue.
  • If an update cannot be applied immediately, remove or disable the plugin to eliminate the vulnerability until the fix is deployed.
  • Deploy a Web Application Firewall or configure server filters to block typical XSS payloads, providing temporary protection against script injection.

Generated by OpenCVE AI on October 10, 2026 at 21:52 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sat, 10 Oct 2026 19:45:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in Barcode Scanner with Inventory & Order Manager <= 1.13.1 versions.
Title WordPress Barcode Scanner with Inventory & Order Manager plugin <= 1.13.1 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-11T11:42:57.844Z

Reserved: 2026-07-13T06:15:14.350Z

Link: CVE-2026-62116

cve-icon Vulnrichment

Updated: 2026-10-11T11:39:55.238Z

cve-icon NVD

Status : Deferred

Published: 2026-10-10T20:16:43.937

Modified: 2026-10-13T13:28:15.717

Link: CVE-2026-62116

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-10T22:00:13Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')