Description
Cross-Site Request Forgery (CSRF) vulnerability in Meow Apps AI Engine ai-engine allows Cross Site Request Forgery.This issue affects AI Engine: from n/a through 3.8.8.
Published: 2026-10-30
Score: 8.8 High
EPSS: n/a
KEV: No
Impact: Cross‑Site Request Forgery
Action: Immediate Patch
AI Analysis

Impact

A flaw in the WordPress AI Engine plugin allows attackers to trick a logged‑in user into sending unauthorized requests to the plugin’s endpoints. The lack of CSRF protection means an attacker can perform any action the user is permitted to do—such as creating or editing content, changing settings, or executing other plugin functions—without the user’s explicit consent. This can lead to integrity violations, unwanted content submissions, and potentially other unintended changes within the WordPress site.

Affected Systems

Meow Apps AI Engine plugin for WordPress, versions from the earliest release through 3.8.8 inclusive, are affected. Only installations of the plugin at or below 3.8.8 are vulnerable; versions 3.8.9 and later contain the fix.

Risk and Exploitability

The CVSS score of 8.8 marks it as a high‑severity flaw. EPSS data is unavailable, so the likelihood of exploitation remains uncertain, but the vulnerability is not listed in CISA’s KEV catalog. Because the attack path requires only the victim to be authenticated and visit a malicious site, an attacker can craft a link or embed a malicious form that, when opened in the user’s browser, triggers the vulnerable plugin to carry out the attacker‑desired actions. The resulting breach can compromise the integrity of site content and potentially expose sensitive information if the plugin processes or stores data in a way that could be abused.

Generated by OpenCVE AI on October 30, 2026 at 17:22 UTC.

Remediation

Vendor Solution

Update the WordPress AI Engine plugin to the latest available version (at least 3.8.9).


OpenCVE Recommended Actions

  • Upgrade the AI Engine plugin to version 3.8.9 or later, which removes the CSRF protection issue.
  • If an upgrade cannot be applied immediately, disable the AI Engine plugin or remove the affected endpoints to prevent the vulnerable code from executing.
  • Apply a general WordPress CSRF mitigation, such as a security plugin that enforces nonce verification, to add an extra layer of request validation until the plugin is updated.

Generated by OpenCVE AI on October 30, 2026 at 17:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 16:30:00 +0000

Type Values Removed Values Added
Description Cross-Site Request Forgery (CSRF) vulnerability in Meow Apps AI Engine ai-engine allows Cross Site Request Forgery.This issue affects AI Engine: from n/a through 3.8.8.
Title WordPress AI Engine plugin <= 3.8.8 - Cross Site Request Forgery (CSRF) vulnerability
Weaknesses CWE-352
References
Metrics cvssV3_1

{'score': 8.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-30T17:18:21.422Z

Reserved: 2026-07-22T08:54:32.759Z

Link: CVE-2026-65566

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-30T17:17:27.793

Modified: 2026-10-30T17:18:40.007

Link: CVE-2026-65566

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T17:30:13Z

Weaknesses
  • CWE-352

    Cross-Site Request Forgery (CSRF)