Impact
Mongoose is an embedded web server and network library; a flaw in the built‑in TLS stack allows an unauthenticated remote peer to send a TLS 1.3 record whose decrypted payload is only the 16‑byte authentication tag. Due to an off‑by‑one length check, the record bypasses proper size validation and causes an underflow in the recv_len calculation, resulting in a heap out‑of‑bounds read before certificate or Finished verification. The attacker can trigger this so that the library treats stale buffer data as a trusted message with an effectively unbounded length. The effect is a remote denial‑of‑service that can be activated without prior authentication or cryptographic credentials. This weakness is exemplified by CWE‑125 (Out‑of‑Bounds Read) and CWE‑191 (Signed/Unsigned Conversion Error).
Affected Systems
Any installation of cesanta’s mongoose library that uses the built‑in TLS stack (MG_TLS_BUILTIN) and is running a version earlier than 7.23 is affected. The issue was fixed in mongoose 7.23, so all releases 7.23 and later are not vulnerable. Users who deploy mongoose inside web servers, embedded devices, or networking software should confirm which major version they have and upgrade accordingly.
Risk and Exploitability
The CVSS score of 7.5 indicates high severity, and the vulnerability can be triggered remotely by sending a carefully crafted TLS 1.3 record to a listening server. No EPSS data is available, so the current exploitation probability cannot be quantified; the issue is not listed in the CISA KEV catalog, suggesting no known widespread exploitation yet. However, because the flaw allows the attacker to execute code that reads arbitrary heap contents, the potential impact on confidentiality, integrity, or availability is significant. An attacker only needs to open a network connection to the affected server; authentication is not required. If the built‑in TLS feature is mandatory, the risk remains until the library is upgraded.
OpenCVE Enrichment