Description
The Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.4.1 via the legacy_render function. This is due to broken authorization on the Lightroom gallery_edit endpoint combined with mass assignment of gallery path and unrestricted file upload into a registered template directory, whose extension check uses a substring match that accepts sanitized .php_ filenames as valid templates. This makes it possible for authenticated attackers, with custom-level access and above, to execute code on the server. Exploitation requires the authenticated attacker to be the stored author of at least one existing NextGEN gallery, as ownership of that gallery is the sole authorization check gating the mass-assignment and upload steps.
Published: 2026-10-30
Score: 7.5 High
EPSS: n/a
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is a Remote Code Execution flaw that allows an attacker to craft a request to the Lightroom 'gallery_edit' endpoint. Because the plugin fails to enforce proper authorization, an attacker with a custom or higher level who is the registered author of at least one gallery can supply a gallery path and an uploaded file. The mass‑assignment and lack of proper extension validation permit the upload of files with a hidden .php suffix. The server then saves the file in the gallery's template directory and loads it as a PHP template, causing the code to be executed with the web server’s privileges.

Affected Systems

The flaw exists in all releases of the NextGEN Gallery WordPress plugin up to and including 4.4.1. The plugin is known as Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery. WordPress sites that use any of these versions and have users with custom‑level or higher access who own a gallery are potentially vulnerable. Administrators should review the installed version and the user roles.

Risk and Exploitability

The CVSS score of 7.5 indicates a high severity. No EPSS score is available, but the lack of check in the KEV catalog suggests that it has not yet been widely exploited. The vulnerability can be triggered remotely over HTTP by an authenticated user, which makes it practical for an attacker who can compromise or guess a user account with gallery ownership. In the absence of a recent exploitation phenomenon, the priority for remediation is still high due to the high impact of remote code execution.

Generated by OpenCVE AI on October 30, 2026 at 18:38 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update NextGEN Gallery plugin to the latest release (4.4.2 or newer) to remove the vulnerable code.
  • If an immediate update is not feasible, deactivate the Lightroom gallery_edit feature or apply a role‑based restriction so that only administrators can access it, then keep galleries unpublished to prevent exploitation.
  • As an intermediate measure, configure the server to deny file execution in the template directory and restrict upload file types to only standard image extensions, eliminating the possibility of saving hidden PHP files.

Generated by OpenCVE AI on October 30, 2026 at 18:38 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 19:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Fri, 30 Oct 2026 19:15:00 +0000

Type Values Removed Values Added
First Time appeared Smub
Smub photo Gallery, Sliders, Proofing And Themes – Nextgen Gallery
Wordpress-extensions
Wordpress-extensions nextgen Gallery
Vendors & Products Smub
Smub photo Gallery, Sliders, Proofing And Themes – Nextgen Gallery
Wordpress-extensions
Wordpress-extensions nextgen Gallery

Fri, 30 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Description The Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.4.1 via the legacy_render function. This is due to broken authorization on the Lightroom gallery_edit endpoint combined with mass assignment of gallery path and unrestricted file upload into a registered template directory, whose extension check uses a substring match that accepts sanitized .php_ filenames as valid templates. This makes it possible for authenticated attackers, with custom-level access and above, to execute code on the server. Exploitation requires the authenticated attacker to be the stored author of at least one existing NextGEN gallery, as ownership of that gallery is the sole authorization check gating the mass-assignment and upload steps.
Title Photo Gallery, Sliders, Proofing and Themes <= 4.4.1 - Authenticated (Custom+) Local File Inclusion via Lightroom 'gallery_edit' Task property_list + Image Upload
Weaknesses CWE-434
References
Metrics cvssV3_1

{'score': 7.5, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

Smub Photo Gallery, Sliders, Proofing And Themes – Nextgen Gallery
Wordpress-extensions Nextgen Gallery
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-30T18:08:55.506Z

Reserved: 2026-08-18T18:59:49.405Z

Link: CVE-2026-76012

cve-icon Vulnrichment

Updated: 2026-10-30T18:00:58.714Z

cve-icon NVD

Status : Deferred

Published: 2026-10-30T18:18:12.937

Modified: 2026-10-30T19:19:10.873

Link: CVE-2026-76012

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T19:00:15Z

Weaknesses
  • CWE-434

    Unrestricted Upload of File with Dangerous Type