Description
In Apache James server prior version 3.9.1 relying on the SieveFileRepository incorect validation of file paths can result in path transversal, allowing to set arbitrary SIEVE scripts for other users.
This allows a logged in attacker to set arbitrary SIEVE scripts for other users, resulting in denial of service or even traffic capture.
Users are recommended to upgrade to version 3.9.1 which fixes this issue.
Published: 2026-11-06
Score: n/a
EPSS: n/a
KEV: No
Impact: Denial of Service
Action: Immediate Patch
AI Analysis

Impact

The vulnerability exists in Apache James server versions older than 3.9.1 due to insufficient validation of file paths in the SieveFileRepository component. A logged‑in user can craft a path that bypasses per‑user isolation and set arbitrary SIEVE scripts for other accounts. This can cause denial of service if a target mailbox becomes corrupted, or it can enable the attacker to capture or modify mail traffic by inserting malicious scripts. The weakness corresponds to the path traversal flaw listed as CWE‑22.

Affected Systems

Apache James server, distributed by the Apache Software Foundation, is vulnerable when running any release prior to 3.9.1. Deployments using older versions should upgrade to 3.9.1 to obtain the fixed path validation logic.

Risk and Exploitability

The flaw requires authenticated access to the server; once the attacker has an account, no additional privileges are needed to trigger the exploit. No publicly available exploit was referenced in the CVE data and the EPSS score is not available. Because the vulnerability allows direct manipulation of other users' scripts, it poses a significant risk of service disruption or traffic interception, justifying prompt remediation. The CVSS score is not reported, but the severity implied by the ability to corrupt mailboxes or intercept traffic suggests a high impact.

Generated by OpenCVE AI on November 6, 2026 at 14:24 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the Apache James version 3.9.1 upgrade to obtain the corrected SieveFileRepository implementation.
  • Restrict which users are permitted to create or modify SIEVE scripts, ensuring only authorized accounts have those permissions.
  • Audit existing user SIEVE scripts for suspicious or abnormal content and remove any that appear to have been inserted via unauthorized means.

Generated by OpenCVE AI on November 6, 2026 at 14:24 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 19:30:00 +0000

Type Values Removed Values Added
References

Fri, 06 Nov 2026 17:00:00 +0000

Type Values Removed Values Added
First Time appeared Apache
Apache james
Vendors & Products Apache
Apache james

Fri, 06 Nov 2026 12:00:00 +0000

Type Values Removed Values Added
Description In Apache James server prior version 3.9.1 relying on the SieveFileRepository incorect validation of file paths can result in path transversal, allowing to set arbitrary SIEVE scripts for other users. This allows a logged in attacker to set arbitrary SIEVE scripts for other users, resulting in denial of service or even traffic capture. Users are recommended to upgrade to version 3.9.1 which fixes this issue.
Title Apache James: ManageSieve file implementation cross-user path traversal
Weaknesses CWE-22
References

cve-icon MITRE

Status: PUBLISHED

Assigner: apache

Published:

Updated: 2026-11-06T19:05:11.062Z

Reserved: 2026-08-19T09:29:58.583Z

Link: CVE-2026-76168

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T12:17:21.783

Modified: 2026-11-06T21:34:42.810

Link: CVE-2026-76168

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T16:33:56Z

Weaknesses
  • CWE-22

    Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')