Description
The FooSales – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 1.43.0. This is due to the plugin not properly validating a user's identity prior to updating their details like email. This makes it possible for authenticated attackers, with FooSales Cashier-level access and above, to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account.
Published: 2026-10-10
Score: 8.8 High
EPSS: < 1% Very Low
KEV: No
Impact: Privilege Escalation
Action: Patch Now
AI Analysis

Impact

The FooSales – Point of Sale plugin for WooCommerce is vulnerable because it fails to verify a user’s identity before permitting changes to user details such as email addresses. An authenticated attacker who holds Cashier-level or higher permissions can alter any user’s email, including that of an administrator. After changing the email, the attacker can initiate a password reset and gain full access to the compromised account. This flaw allows an attacker to take over accounts and elevate privileges, potentially leading to unauthorized system access, data theft, or further exploitation. The weakness corresponds to CWE‑269: Improper Privilege Management.

Affected Systems

The vulnerability affects all installations of the FooSales plugin for WooCommerce up to and including version 1.43.0. No patch version is specified in the data, but the issue exists across the entire affected range.

Risk and Exploitability

With a CVSS score of 8.8, the flaw is considered high severity. EPSS availability is not reported, so the likelihood of exploitation cannot be precisely quantified at this time. The vulnerability is not listed in CISA’s KEV catalog, indicating no confirmed public exploits. The attack vector requires an authenticated user with Cashier-level or higher rights; the attacker must send a request to the create_update_customer REST endpoint to change another user’s email. Given the broad reach of the role and the ability to reset passwords, the risk to sites running older versions of the plugin is significant.

Generated by OpenCVE AI on October 10, 2026 at 06:39 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the FooSales plugin to the latest version that includes the privilege validation fix
  • Restrict the Cashier role to trusted accounts only, removing it from users who should not modify other user data
  • Configure WordPress to disable or limit REST API access for the create_update_customer endpoint, or enforce additional access controls such as two‑factor authentication for sensitive actions

Generated by OpenCVE AI on October 10, 2026 at 06:39 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Sat, 10 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The FooSales – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 1.43.0. This is due to the plugin not properly validating a user's identity prior to updating their details like email. This makes it possible for authenticated attackers, with FooSales Cashier-level access and above, to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account.
Title FooSales <= 1.43.0 - Authenticated (Custom+) Privilege Escalation via create_update_customer REST Endpoint
Weaknesses CWE-269
References
Metrics cvssV3_1

{'score': 8.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-11T16:55:17.453Z

Reserved: 2026-08-20T15:39:24.587Z

Link: CVE-2026-77183

cve-icon Vulnrichment

Updated: 2026-10-11T16:45:54.356Z

cve-icon NVD

Status : Deferred

Published: 2026-10-10T06:16:43.013

Modified: 2026-10-13T13:29:12.567

Link: CVE-2026-77183

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-10T06:45:17Z

Weaknesses
  • CWE-269

    Improper Privilege Management