Description
The Post and Page Builder by BoldGrid – Visual Drag and Drop Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Table Designer 'data-label' Attribute in all versions up to, and including, 1.27.13 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-15
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting in post pages
Action: Apply Patch
AI Analysis

Impact

The Post and Page Builder by BoldGrid – Visual Drag and Drop Editor contains a stored XSS flaw that occurs when the Table Designer 'data-label' attribute is not properly sanitized or escaped. Attackers with Contributor level or higher can place arbitrary JavaScript code into that attribute, causing the code to run whenever any user opens the affected page. This weakness allows arbitrary script execution in the victim’s browser, potentially enabling session hijacking, data theft, or defacement.

Affected Systems

All installations of the Post and Page Builder by BoldGrid – Visual Drag and Drop Editor plugin running version 1.27.13 or earlier are vulnerable. The plugin is used in WordPress sites that employ the drag‑and‑drop editor for page construction.

Risk and Exploitability

The affected vulnerability has a CVSS score of 6.4, indicating a moderate severity. Because the attack requires authenticated access with Contributor or higher privileges, the attack surface is limited to trusted users of a WordPress site. Exploit probability is unknown due to missing EPSS information, and the issue is not listed in the CISA KEV catalog. If an attacker gains the necessary role, they can add malicious scripts and compromise the confidentiality and integrity of site content, and potentially affect availability by injecting malicious redirects. Given the potential impact on user sessions, the vulnerability should be treated as high priority.

Generated by OpenCVE AI on October 15, 2026 at 11:50 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Post and Page Builder plugin to version 1.27.14 or later, which removes the vulnerable attribute handling. This is the official fix provided by the plugin maintainer.
  • Immediately review and remove any custom code or other plugins that add or modify the 'data-label' attribute in Table Designer components.
  • Audit existing page content for injected scripts and delete any that are found, and consider deploying a web‑application firewall rule to block suspicious payloads.

Generated by OpenCVE AI on October 15, 2026 at 11:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 18 Oct 2026 05:30:00 +0000

Type Values Removed Values Added
First Time appeared Boldgrid
Boldgrid post And Page Builder By Boldgrid - Visual Drag And Drop Editor
Wordpress-extensions
Wordpress-extensions post And Page Builder By Boldgrid
Vendors & Products Boldgrid
Boldgrid post And Page Builder By Boldgrid - Visual Drag And Drop Editor
Wordpress-extensions
Wordpress-extensions post And Page Builder By Boldgrid

Thu, 15 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 15 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The Post and Page Builder by BoldGrid – Visual Drag and Drop Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Table Designer 'data-label' Attribute in all versions up to, and including, 1.27.13 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title Post and Page Builder by BoldGrid <= 1.27.13 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'data-label' Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

Boldgrid Post And Page Builder By Boldgrid - Visual Drag And Drop Editor
Wordpress-extensions Post And Page Builder By Boldgrid
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-15T16:43:41.835Z

Reserved: 2026-08-21T19:30:48.931Z

Link: CVE-2026-78001

cve-icon Vulnrichment

Updated: 2026-10-15T16:38:17.895Z

cve-icon NVD

Status : Deferred

Published: 2026-10-15T06:17:04.623

Modified: 2026-10-15T17:17:28.137

Link: CVE-2026-78001

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-18T05:15:05Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')