Description
The VK Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Group Block 'linkToPost' Feature in all versions up to, and including, 1.126.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-15
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross-Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The VK Blocks plugin for WordPress embeds a stored cross‑site scripting flaw within the Group Block titled "linkToPost." Inversions of input validation and output escaping allow an authenticated contributor or higher user to inject arbitrary JavaScript into a page. Because the script executes in the context of any visitor who opens that page, attackers can hijack user sessions, inject malicious code, or alter page content. The damage can range from defacement to credential theft, depending on the victim’s role and privileges on the site.

Affected Systems

All installations of the VK Blocks plugin from its initial release through version 1.126.1 are vulnerable. The flaw is present in the vektor‑inc:VK Blocks WordPress plugin, specifically within the linkToPost group block feature. Any WordPress site that has not upgraded beyond 1.126.1 falls under this risk.

Risk and Exploitability

The CVSS score of 6.4 indicates a moderate risk level, with the vulnerability exploitable only by users who already possess contributor‑level access. No EPSS or KEV data suggest that widespread exploitation has not yet been observed. Attackers must first authenticate and then use the vulnerable block to place their malicious scripts, after which the scripts run in browsers of all page visitors. The moderate severity, combined with the requirement for authenticated access, means that careful role management can reduce the attack surface, but an out‑of‑band update is recommended.

Generated by OpenCVE AI on October 15, 2026 at 11:20 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the latest version of the VK Blocks plugin that addresses the linkToPost XSS flaw
  • Limit Contributor and higher user roles to only trusted individuals and consider disabling the linkToPost block for these roles
  • If an upgrade is temporarily unavailable, remove the linkToPost block from any content or restrict its use to non‑interactive parts of the site

Generated by OpenCVE AI on October 15, 2026 at 11:20 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 15 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 15 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The VK Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Group Block 'linkToPost' Feature in all versions up to, and including, 1.126.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title VK Blocks <= 1.126.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Group Block 'linkToPost' Feature
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-15T16:43:40.380Z

Reserved: 2026-08-22T15:11:56.743Z

Link: CVE-2026-78087

cve-icon Vulnrichment

Updated: 2026-10-15T16:37:55.937Z

cve-icon NVD

Status : Deferred

Published: 2026-10-15T06:17:04.787

Modified: 2026-10-15T17:17:28.240

Link: CVE-2026-78087

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-15T11:30:18Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')