Description
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.
Published: 2026-10-12
Score: 8.7 High
EPSS: < 1% Very Low
KEV: No
Impact: Account Takeover
Action: Immediate Patch
AI Analysis

Impact

Nginx UI, a web interface for Nginx, had a bug on the /api/users/:id user‑management endpoint. The endpoint allowed any authenticated user to change anyone else's password without requiring the RequireSecureSession step‑up that the self‑service password‑change flow mandates. This omission gives an attacker who has logged into the application the ability to reset the administrator’s password, invalidate the administrator’s existing session tokens, and then authenticate as the administrator. The flaw is a classic authentication bypass and privileged‑escalation weakness (CWE‑285) that also violates the principle of least authorization (CWE‑862).

Affected Systems

Vendor 0xJacky, product Nginx UI, all releases prior to 2.4.1 are vulnerable. Versions 2.4.1 and newer include the security fix that enforces RequireSecureSession on the user‑management API.

Risk and Exploitability

The vulnerability has a CVSS score of 8.7, classifying it as high severity. It is not listed in the CISA KEV catalog and the EPSS score is unavailable, but the low access requirement—an authenticated account—means the exploitability is high. An attacker only needs to log into the UI to change the administrator password; the path is remote and does not require special network segments or elevated permissions. Consequently the risk to systems running affected Nginx UI versions is significant, especially when default or weak credentials are used.

Generated by OpenCVE AI on October 12, 2026 at 22:52 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Nginx UI to version 2.4.1 or later, where RequireSecureSession is enforced on the user‑management endpoint.
  • If an upgrade cannot be performed immediately, restrict access to the /api/users/:id endpoint using firewall rules or network segmentation so that only trusted administrator accounts can reach it.
  • Apply any vendor‑supplied patch or configuration that restores RequireSecureSession enforcement to all user‑management actions, and verify that the step‑up challenge is required for password changes.

Generated by OpenCVE AI on October 12, 2026 at 22:52 UTC.

Tracking

Sign in to view the affected projects.

Advisories
Source ID Title
Github GHSA Github GHSA GHSA-2gc7-j998-5xx6 Nginx UI: Account Takeover via Missing `RequireSecureSession` on User Management Endpoint
History

Tue, 13 Oct 2026 18:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'poc', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Tue, 13 Oct 2026 00:00:00 +0000

Type Values Removed Values Added
First Time appeared 0xjacky
0xjacky nginx-ui
Vendors & Products 0xjacky
0xjacky nginx-ui

Mon, 12 Oct 2026 21:00:00 +0000

Type Values Removed Values Added
Description Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.
Title Nginx UI: Account Takeover via Missing `RequireSecureSession` on User Management Endpoint
Weaknesses CWE-285
CWE-862
References
Metrics cvssV4_0

{'score': 8.7, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N'}


Subscriptions

0xjacky Nginx-ui
cve-icon MITRE

Status: PUBLISHED

Assigner: GitHub_M

Published:

Updated: 2026-10-13T17:32:02.947Z

Reserved: 2026-09-01T16:17:43.079Z

Link: CVE-2026-84314

cve-icon Vulnrichment

Updated: 2026-10-13T17:31:41.082Z

cve-icon NVD

Status : Deferred

Published: 2026-10-12T21:17:21.753

Modified: 2026-10-13T18:17:25.927

Link: CVE-2026-84314

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-12T23:45:12Z

Weaknesses