Description
The Video Player for YouTube WordPress plugin before 2.1.4 does not perform a capability check on its player-preset AJAX handler, allowing users with the Contributor role and above to read the site-wide player-preset configuration, and in versions before 2.1.1 to modify and delete it as well.
Published: 2026-10-29
Score: 3.8 Low
EPSS: < 1% Very Low
KEV: No
Impact: Unauthorized Reading and Modification of Player Configuration via Missing Authorization
Action: Patch Now
AI Analysis

Impact

The Video Player for YouTube WordPress plugin contains a flaw in its AJAX handler, failing to verify the user’s capability. Users assigned the Contributor role or higher can fetch the entire site‑wide player‑preset configuration, and in older releases (before 2.1.1) may also alter or delete that configuration. This enables an attacker who can log in as a contributor to inspect or change plugin settings without proper approval, potentially disrupting playback behavior or enabling malicious scripts embedded in the configuration.

Affected Systems

WordPress sites running the Video Player for YouTube plugin versions older than 2.1.4 are affected. Versions earlier than 2.1.1 expose even greater risk by allowing configuration modification and deletion. Any WordPress installation that has this plugin installed and accepts contributors or higher roles is at risk; users should verify their plugin version and disable or remove the plugin if an upgrade is not possible.

Risk and Exploitability

The vulnerability is exploitable through the public AJAX endpoint exposed by the plugin, but an attacker must be authenticated as a user with the Contributor role or higher. This limitation reduces the attack surface to authenticated users, yet the lack of a capability check means that any such user gains unintended read and write access to plugin settings. Because EPSS data is not available and the issue is not listed in the CISA KEV catalog, no public exploit data is currently known; however, the potential impact on configuration integrity and site behavior warrants prompt remediation. The CVSS score is 3.8; the flaw satisfies CWE-284: Improper Access Control.

Generated by OpenCVE AI on October 29, 2026 at 13:08 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Video Player for YouTube plugin to version 2.1.4 or later
  • Restrict Contributor and higher role assignments by reviewing user permissions
  • If upgrade not possible, disable or remove the plugin to prevent unauthorized access

Generated by OpenCVE AI on October 29, 2026 at 13:08 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 3.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N'}

ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 29 Oct 2026 08:15:00 +0000

Type Values Removed Values Added
Weaknesses CWE-284

Thu, 29 Oct 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Video Player for YouTube WordPress plugin before 2.1.4 does not perform a capability check on its player-preset AJAX handler, allowing users with the Contributor role and above to read the site-wide player-preset configuration, and in versions before 2.1.1 to modify and delete it as well.
Title YT Player < 2.1.4 - Contributor+ Missing Authorization via ytp_ajax
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-29T10:46:16.022Z

Reserved: 2026-09-02T18:34:44.252Z

Link: CVE-2026-85007

cve-icon Vulnrichment

Updated: 2026-10-29T10:45:44.100Z

cve-icon NVD

Status : Received

Published: 2026-10-29T06:17:24.230

Modified: 2026-10-29T11:17:35.440

Link: CVE-2026-85007

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T13:15:15Z

Weaknesses