Description
The Pricing Table WordPress plugin before 2.1.5 does not validate the scheme of a user-supplied link value in one of its blocks before rendering it, allowing users with contributor-level access and above to store malicious scripts that execute when another user views and interacts with the affected content.
Published: 2026-10-14
Score: 6.8 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting via contributor‑level access
Action: Patch Now
AI Analysis

Impact

The Pricing Table WordPress plugin, versions 1.0.7 through 2.1.4, fails to validate the scheme of a user‑supplied link in a pricing block, allowing users with contributor or higher privileges to inject malicious scripts that run when other visitors view the affected content. This stored XSS flaw can lead to defacement, credential theft, or other client‑side attacks against any user who opens the page containing the block.

Affected Systems

WordPress sites using the Pricing Table plugin between versions 1.0.7 and 2.1.4 are impacted. The vendor is listed only as "Pricing Table," with no additional product detail, and affected versions span the full range of releases up to 2.1.4.

Risk and Exploitability

The vulnerability carries a CVSS score of 6.8, indicating moderate severity, and an EPSS score of less than 1 %, implying a low probability of exploitation in the wild. It is not included in the CISA KEV catalog. The attack requires a contributor‑level account to store the payload; once embedded, any visitor to the pricing block will execute the code. The stored nature of the flaw amplifies its impact, as the malicious script can persist indefinitely until the block is edited or the plugin is updated.

Generated by OpenCVE AI on October 16, 2026 at 00:33 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Pricing Table plugin to version 2.1.5 or newer, which incorporates a validation fix for link schemes.
  • Disable the link input in existing pricing blocks or manually remove any embedded scripts until the plugin is updated.
  • Limit contributor privileges or revoke contributor access until the vulnerable plugin is patched.

Generated by OpenCVE AI on October 16, 2026 at 00:33 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 14 Oct 2026 14:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79
Metrics cvssV3_1

{'score': 6.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H'}


Wed, 14 Oct 2026 06:45:00 +0000

Type Values Removed Values Added
Description The Pricing Table WordPress plugin before 2.1.5 does not validate the scheme of a user-supplied link value in one of its blocks before rendering it, allowing users with contributor-level access and above to store malicious scripts that execute when another user views and interacts with the affected content.
Title Pricing Table Block 1.0.7 - 2.1.4 - Contributor+ Stored XSS via Pricing Link
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-14T13:42:21.536Z

Reserved: 2026-09-08T12:13:06.558Z

Link: CVE-2026-86797

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-14T07:17:03.753

Modified: 2026-10-14T16:14:02.800

Link: CVE-2026-86797

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-16T00:45:17Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')