Description
The The Ocean Extra plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.6.0 This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Published: 2026-10-15
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Remote Code Execution
Action: Patch Now
AI Analysis

Impact

The Ocean Extra plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to and including 2.6.0. The flaw allows the plugin to run do_shortcode on user-supplied values without proper validation, enabling an attacker to inject and execute any shortcode, which can lead to remote code execution depending on the shortcode’s payload. The vulnerability is exploitable by unauthenticated users, meaning anyone who can send a request to the site may trigger it.

Affected Systems

This issue affects the Ocean Extra plugin provided by oceanwp. Any WordPress installation that has Ocean Extra installed in a version equal to or older than 2.6.0 is impacted. No additional vendors or products are listed as affected.

Risk and Exploitability

The CVSS score of 6.5 places the flaw in the moderate severity range. Although the EPSS score is not available and the vulnerability has not been listed in CISA’s KEV catalog, the ability for unauthenticated attackers to trigger the flaw through crafted requests presents a tangible risk. Based on the description, it is inferred that an attacker can send a request containing a malicious shortcode to the site, which will be executed by the plugin without further checks. The lack of authentication requirements lowers the effort needed to exploit this vulnerability, heightening its practical impact in environments with the affected plugin deployed.

Generated by OpenCVE AI on October 15, 2026 at 11:26 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Ocean Extra to the latest available version to remove the vulnerable code.
  • If an immediate update is not possible, temporarily disable the "oceanwp_library" shortcode by removing its registration in the plugin code or adding a line in a child theme’s functions.php to unhook the shortcode.
  • Verify that the site no longer processes arbitrary shortcodes by testing the site with a simple, harmless shortcode and confirming no execution occurs.

Generated by OpenCVE AI on October 15, 2026 at 11:26 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 15 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 15 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The The Ocean Extra plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.6.0 This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Title Ocean Extra <= 2.6.0 - Unauthenticated Arbitrary Shortcode Execution via 'oceanwp_library' Shortcode Template
Weaknesses CWE-94
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-15T16:43:41.589Z

Reserved: 2026-09-08T12:41:15.637Z

Link: CVE-2026-86803

cve-icon Vulnrichment

Updated: 2026-10-15T16:38:16.263Z

cve-icon NVD

Status : Deferred

Published: 2026-10-15T06:17:05.327

Modified: 2026-10-15T17:17:29.570

Link: CVE-2026-86803

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-15T11:30:18Z

Weaknesses
  • CWE-94

    Improper Control of Generation of Code ('Code Injection')