Description
The Popup Builder – Create highly converting, mobile friendly marketing popups. plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.4.5 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to trash all published popups on the site with a single unauthenticated GET request. The attack is amplified by a second flaw in SGPopup::find(), which returns false for every normally published popup when the sg_popup_preview_id parameter is present, causing the trash branch to fire against every popup on the site simultaneously.
Published: 2026-10-31
Score: 9.1 Critical
EPSS: n/a
KEV: No
Impact: Unauthorized deletion of all popups, compromising site functionality and data integrity
Action: Patch Immediately
AI Analysis

Impact

The Popup Builder plugin for WordPress suffers from an authorization bypass that allows any unauthenticated user to issue a GET request that triggers the trashing of all published popups. Because the plugin fails to verify the user's privileges before performing delete operations, an attacker can instantly remove every popup on the site. The vulnerability also exploits a secondary flaw in the SGPopup::find() method, which returns false for normally published popups when the sg_popup_preview_id parameter is present, forcing the trash logic to execute against each popup and amplifying the impact. The result is a wholesale loss of marketing popups, which can disrupt revenue‑generating mechanisms and alter site appearance.

Affected Systems

All installations of the Popup Builder plugin for WordPress, version 4.4.5 and earlier. No auxiliary versions are explicitly listed, so any deployment using version 4.4.5 or older is potentially vulnerable.

Risk and Exploitability

The CVSS score of 9.1 indicates high severity. Because the flaw can be exploited with a simple unauthenticated GET request and no authentication barrier, the risk is high. The EPSS score is not available, but the lack of restrictions and the amplification bug make exploitation likely. The vulnerability is not part of the CISA KEV catalog, yet the absence of a patch until a newer release necessitates urgent action. Attackers only need network visibility to the site and can trigger the deletion with no credentials.

Generated by OpenCVE AI on October 31, 2026 at 08:28 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update to the latest Popup Builder version (4.4.6 or later).
  • If an immediate update is not feasible, restrict external access to the site’s admin and plugin endpoints using firewalls or VPN to block unauthenticated GET requests.
  • Disable or uninstall the plugin if it is not critical to site operations.

Generated by OpenCVE AI on October 31, 2026 at 08:28 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 31 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Popup Builder – Create highly converting, mobile friendly marketing popups. plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.4.5 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to trash all published popups on the site with a single unauthenticated GET request. The attack is amplified by a second flaw in SGPopup::find(), which returns false for every normally published popup when the sg_popup_preview_id parameter is present, causing the trash branch to fire against every popup on the site simultaneously.
Title Popup Builder <= 4.4.5 - Missing Authorization to Unauthenticated Arbitrary Popup Post Trashing via 'post_type' and 'sg_popup_preview_id' Parameters
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 9.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-31T06:44:14.491Z

Reserved: 2026-09-11T11:01:45.127Z

Link: CVE-2026-89270

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-31T07:16:37.707

Modified: 2026-10-31T07:16:37.707

Link: CVE-2026-89270

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-31T08:30:13Z

Weaknesses