Description
The WP Verify API WordPress plugin through 1.0.0 does not properly sanitize and escape a parameter before using it in a SQL query, allowing unauthenticated users to perform SQL injection attacks.
Published: 2026-10-11
Score: 8.6 High
EPSS: < 1% Very Low
KEV: No
Impact: Unauthenticated SQL injection via unsanitized parameter in a WordPress plugin
Action: Patch immediately
AI Analysis

Impact

The WP Verify API plugin, through version 1.0.0, fails to properly sanitize or escape the value of the 'verify' parameter before it is incorporated into a SQL query. As a result, any user who can access the endpoint can manipulate the parameter to inject arbitrary SQL statements, potentially exposing sensitive data or modifying the database. This flaw is a classic example of SQL injection, enabling attackers to read, change, or delete critical information stored by the application.

Affected Systems

WordPress sites that have installed the WP Verify API plugin, specifically versions 1.0.0 or earlier. The vulnerability exists regardless of the website’s user authentication state due to the lack of input validation.

Risk and Exploitability

The flaw is exploitable without authentication, allowing an attacker to send malicious requests to the vulnerable endpoint. The EPSS score of <1% indicates a low but measurable probability of exploitation, while the CVSS score of 8.6 classifies the vulnerability as high severity. The issue is not listed in CISA KEV, but the combination of unauthenticated access and significant impact elevates the risk of data compromise or disruption.

Generated by OpenCVE AI on October 11, 2026 at 16:26 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade to the latest WP Verify API plugin release that removes the vulnerability
  • If upgrading is not immediately possible, disable or uninstall the plugin to eliminate the attack surface
  • Add request filtering rules or web application firewall rules to block known SQL injection payload patterns directed at the affected endpoint

Generated by OpenCVE AI on October 11, 2026 at 16:26 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 20 Oct 2026 12:45:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions wp Verify Api
Vendors & Products Wordpress-extensions
Wordpress-extensions wp Verify Api

Sun, 11 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-20

Sun, 11 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 8.6, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N'}

ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sun, 11 Oct 2026 08:15:00 +0000

Type Values Removed Values Added
Weaknesses CWE-20
CWE-89

Sun, 11 Oct 2026 06:30:00 +0000

Type Values Removed Values Added
Description The WP Verify API WordPress plugin through 1.0.0 does not properly sanitize and escape a parameter before using it in a SQL query, allowing unauthenticated users to perform SQL injection attacks.
Title WP Verify API <= 1.0.0 - Unauthenticated SQLi via 'verify' Parameter
References

Subscriptions

Wordpress-extensions Wp Verify Api
cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-11T11:32:40.885Z

Reserved: 2026-09-11T13:18:06.942Z

Link: CVE-2026-89299

cve-icon Vulnrichment

Updated: 2026-10-11T11:14:53.005Z

cve-icon NVD

Status : Deferred

Published: 2026-10-11T07:17:28.770

Modified: 2026-10-13T16:29:21.907

Link: CVE-2026-89299

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-20T10:15:13Z

Weaknesses
  • CWE-89

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')