Description
The Subscribe to Comments WordPress plugin before 2.3.3 does not properly validate a parameter before reflecting it into a link target, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting via a crafted URL against anyone who clicks it, including administrators.
Published: 2026-10-11
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Reflected XSS
Action: Update
AI Analysis

Impact

The plugin does not properly validate or sanitize the ‘ref’ query parameter before reflecting it in a link target. This allows an unauthenticated attacker to create a crafted URL that, when clicked by any user, executes arbitrary JavaScript in the victim’s browser. The attack can compromise confidentiality, integrity, and availability of user sessions and can be used to deface the site or redirect users to malicious destinations.

Affected Systems

Because the vulnerability exists in all versions of the Subscribe to Comments WordPress plugin prior to 2.3.3, any WordPress installation that has the plugin installed and not yet updated is affected. The plugin is not tied to a recognized vendor in the CNA list, so administrators must review their WordPress instances for the presence of this plugin and verify that the installed version is newer than 2.3.3.

Risk and Exploitability

The EPSS score of less than 1% indicates a low probability of exploitation, although reflected XSS vulnerabilities can still be leveraged via social engineering. The vulnerability is listed in CISA KEV as not present, but the absence of an official advisory does not reduce its risk. The attack vector is reflected XSS via an HTTPS or HTTP link that an attacker can send to any user, including administrators, making the likelihood of exploitation significant in an environment where social engineering or malicious links are possible. The CVSS score of 7.1 indicates high severity, but the potential for privilege abuse and data theft is high.

Generated by OpenCVE AI on October 11, 2026 at 15:07 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Subscribe to Comments plugin to version 2.3.3 or later.
  • If the plugin is no longer needed, uninstall it.
  • Deploy a strict Content‑Security‑Policy that disallows inline scripts and limits allowed sources.
  • Monitor for suspicious links or script execution attempts.

Generated by OpenCVE AI on October 11, 2026 at 15:07 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}

ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sun, 11 Oct 2026 08:15:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79

Sun, 11 Oct 2026 06:30:00 +0000

Type Values Removed Values Added
Description The Subscribe to Comments WordPress plugin before 2.3.3 does not properly validate a parameter before reflecting it into a link target, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting via a crafted URL against anyone who clicks it, including administrators.
Title Subscribe to Comments < 2.3.3 - Reflected XSS via 'ref' Parameter
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-11T11:32:40.394Z

Reserved: 2026-09-15T08:14:17.296Z

Link: CVE-2026-91829

cve-icon Vulnrichment

Updated: 2026-10-11T11:14:04.809Z

cve-icon NVD

Status : Deferred

Published: 2026-10-11T07:17:29.193

Modified: 2026-10-13T16:29:21.907

Link: CVE-2026-91829

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-11T15:15:09Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')