Description
The FooSales WordPress plugin before 1.43.3 does not verify that an authenticated caller is entitled to act as the user a request names, allowing any authenticated user to have the FooSales WordPress plugin before 1.43.3 act as an arbitrary other user, including an administrator, resulting in that user's account details being exposed and their account being taken over.
Published: 2026-10-09
Score: 8.8 High
EPSS: < 1% Very Low
KEV: No
Impact: Privilege Escalation via User Impersonation
Action: Patch Now
AI Analysis

Impact

The FooSales WordPress plugin before 1.43.3 does not verify that an authenticated caller is entitled to act as the user specified in a request, allowing any logged‑in user to impersonate any other user, including administrators. This flaw permits an attacker to obtain sensitive account details, take over the target account, and compromise the integrity and confidentiality of the site. The weakness is an authorization bypass, reflected by CWE‑269.

Affected Systems

This issue appears in all WordPress installations that the FooSales plugin with a version lower than 1.43.3. Any site that has not upgraded to 1.43.3 or newer is susceptible, regardless of the site’s user base or configuration.

Risk and Exploitability

The flaw scores a CVSS of 8.8, indicating high severity. Even with an EPSS of less than 1%, the lack of access controls means a credentialed attacker can easily structure the required requests, so the likelihood of exploitation remains significant once an account is compromised. The vulnerability is not listed in CISA’s KEV catalog, but the difficulty of the attack is low, making it a priority for remediation.

Generated by OpenCVE AI on October 9, 2026 at 18:39 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the FooSales plugin to version 1.43.3 or later.
  • If an update cannot be performed immediately, disable or restrict the plugin’s impersonation feature.
  • Reevaluate and tighten WordPress role permissions so that only trusted administrators can perform high‑privilege actions.
  • Monitor WordPress logs for suspicious impersonation attempts and set up alerts for abnormal activity.

Generated by OpenCVE AI on October 9, 2026 at 18:39 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 09 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-285

Fri, 09 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-269
Metrics cvssV3_1

{'score': 8.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'}

ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Fri, 09 Oct 2026 08:15:00 +0000

Type Values Removed Values Added
Weaknesses CWE-285

Fri, 09 Oct 2026 06:45:00 +0000

Type Values Removed Values Added
Description The FooSales WordPress plugin before 1.43.3 does not verify that an authenticated caller is entitled to act as the user a request names, allowing any authenticated user to have the FooSales WordPress plugin before 1.43.3 act as an arbitrary other user, including an administrator, resulting in that user's account details being exposed and their account being taken over.
Title FooSales < 1.43.3 - Subscriber+ Privilege Escalation via User Impersonation
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-09T14:50:08.442Z

Reserved: 2026-09-18T09:23:56.665Z

Link: CVE-2026-93548

cve-icon Vulnrichment

Updated: 2026-10-09T14:44:44.776Z

cve-icon NVD

Status : Deferred

Published: 2026-10-09T07:17:19.247

Modified: 2026-10-09T15:17:20.140

Link: CVE-2026-93548

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T18:45:10Z

Weaknesses
  • CWE-269

    Improper Privilege Management