Description
The Aurora Heatmap plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘url’ parameter in all versions up to, and including, 1.7.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an admin user clicks the injected heatmap link.
Published: 2026-10-07
Score: 6.1 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Unauthenticated Stored Cross‑Site Scripting via the 'url' parameter, allowing arbitrary scripts to execute as an admin when a link is clicked
Action: Immediate Patch
AI Analysis

Impact

The Aurora Heatmap plugin for WordPress stores user‑supplied data in the 'url' parameter without sufficient sanitization or escaping. When an admin later clicks the heatmap link, the injected script is executed with the admin's privileges, potentially allowing theft of credentials, defacement of site content, or further compromise of the system. This reflected behaviour matches the input validation weakness identified by CWE‑79.

Affected Systems

All installations of the Aurora Heatmap plugin, version 1.7.2 or earlier. The vulnerability impacts the WordPress platform wherever this plugin is active and the 'url' parameter is used to configure heatmap links.

Risk and Exploitability

The vulnerability has a CVSS score of 6.1, placing it in the moderate severity range. No EPSS score is available, and it is not listed in CISA's KEV catalog, suggesting no confirmed exploitation reports at this time. The likely attack vector is a simple unauthenticated HTTP request that submits a malicious URL to the plugin. Once the data is stored, any subsequent admin click triggers the payload, giving attackers a straightforward route to compromise the administration interface and potentially the underlying application.

Generated by OpenCVE AI on October 8, 2026 at 00:50 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Aurora Heatmap to a version newer than 1.7.2 to remove the stored XSS flaw
  • If an upgrade is not immediately possible, disable the Aurora Heatmap plugin or at least block the 'url' parameter from accepting external input
  • Monitor the WordPress admin area for unauthorized script execution attempts or anomalous URL parameters, and audit usage logs to detect potential exploitation

Generated by OpenCVE AI on October 8, 2026 at 00:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 09 Oct 2026 09:15:00 +0000

Type Values Removed Values Added
First Time appeared R3098
R3098 aurora Heatmap
Wordpress-extensions
Wordpress-extensions aurora Heatmap
Vendors & Products R3098
R3098 aurora Heatmap
Wordpress-extensions
Wordpress-extensions aurora Heatmap

Thu, 08 Oct 2026 15:15:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 07 Oct 2026 23:45:00 +0000

Type Values Removed Values Added
Description The Aurora Heatmap plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘url’ parameter in all versions up to, and including, 1.7.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an admin user clicks the injected heatmap link.
Title Aurora Heatmap <= 1.7.2 - Unauthenticated Stored Cross-Site Scripting via 'url' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N'}


Subscriptions

R3098 Aurora Heatmap
Wordpress-extensions Aurora Heatmap
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-08T14:25:35.533Z

Reserved: 2026-09-20T22:56:50.493Z

Link: CVE-2026-94154

cve-icon Vulnrichment

Updated: 2026-10-08T14:25:32.411Z

cve-icon NVD

Status : Deferred

Published: 2026-10-08T00:16:35.333

Modified: 2026-10-08T17:24:31.040

Link: CVE-2026-94154

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T08:14:13Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')