Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Theme-one The Grid the-grid allows Command Injection.This issue affects The Grid: from n/a through 2.8.1.
Published: 2026-10-16
Score: 10 Critical
EPSS: 4.4% Low
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

This vulnerability is an improper control of code generation flaw that allows an attacker to inject arbitrary code through the Theme‑one The Grid plugin. The flaw enables command injection, giving the attacker the ability to execute arbitrary system commands on the host web server. The weakness maps to CWE‑94 and is described as a code injection vulnerability. The impact includes complete loss of confidentiality, integrity, and availability for affected sites, potentially allowing an attacker to compromise the entire WordPress installation.

Affected Systems

The affected product is the WordPress The Grid plugin developed by Theme‑one. Versions from the earliest available release up to and including 2.8.1 are impacted, while 2.8.2 and later are considered fixed.

Risk and Exploitability

The CVSS score of 10 indicates the highest severity possible, and the EPSS score is 4%, implying a very low but nonzero probability of exploitation; the vulnerability is not listed in CISA KEV. Based on the description, the likely attack vector is remote, as the plugin is accessible through the WordPress administrative interface or via public plugin endpoints. An attacker with remote access to the WordPress site can trigger the code injection and gain full server compromise. The vulnerability has no documented mitigations beyond patching and is not in a public exploitation catalog.

Generated by OpenCVE AI on October 25, 2026 at 19:52 UTC.

Remediation

Vendor Solution

Update the WordPress The Grid plugin to the latest available version (at least 2.8.2).


OpenCVE Recommended Actions

  • Update the WordPress The Grid plugin to version 2.8.2 or later.
  • If the plugin is not essential, uninstall it or replace it with a secure alternative that does not expose code injection points.
  • Audit the WordPress installation for other outdated or vulnerable plugins and ensure they are kept up to date or removed.

Generated by OpenCVE AI on October 25, 2026 at 19:52 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 16 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Fri, 16 Oct 2026 07:15:00 +0000

Type Values Removed Values Added
Description Improper Control of Generation of Code ('Code Injection') vulnerability in Theme-one The Grid the-grid allows Command Injection.This issue affects The Grid: from n/a through 2.8.1.
Title WordPress The Grid plugin <= 2.8.1 - Remote Code Execution (RCE) vulnerability
Weaknesses CWE-94
References
Metrics cvssV3_1

{'score': 10, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-16T18:38:00.753Z

Reserved: 2026-09-21T00:20:20.797Z

Link: CVE-2026-94169

cve-icon Vulnrichment

Updated: 2026-10-16T14:19:56.112Z

cve-icon NVD

Status : Deferred

Published: 2026-10-16T07:17:14.297

Modified: 2026-10-16T15:19:36.177

Link: CVE-2026-94169

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-25T20:00:16Z

Weaknesses
  • CWE-94

    Improper Control of Generation of Code ('Code Injection')