Description
The Loco Translate WordPress plugin before 2.8.9 does not restrict which file paths its translation file routes will read, allowing users granted the Loco Translate WordPress plugin before 2.8.9's translator capability to retrieve the contents of files of certain types from anywhere on the server, including outside the web root.
Published: 2026-10-03
Score: 6.8 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Arbitrary file read
Action: Upgrade plugin
AI Analysis

Impact

The Loco Translate WordPress plugin before version 2.8.9 does not validate the file path used by its translation file routes. A user with translator privileges can supply a path parameter that points to any readable file on the server. The plugin then opens and returns the contents of that file, enabling the extraction of information such as configuration data or credentials. This flaw constitutes a file‑read vulnerability; it does not allow code execution or modification of files.

Affected Systems

WordPress installations that have the Loco Translate plugin installed with a version earlier than 2.8.9. The vulnerability is exercised when a user with the translator role accesses the plugin’s translation file route and supplies a path that points inside or outside the web root. Sites that lack the plugin or run a newer version are not affected.

Risk and Exploitability

The EPSS score of 0.00157 (<1%) indicates a very low probability of exploitation, and the vulnerability is not listed in the CISA KEV catalog, suggesting no known active exploitation. The flaw requires the attacker to possess translator capabilities, which typically ties to authenticated users. The risk remains moderate for sites that expose the translator role to untrusted users; once the role is obtained, any readable file can be retrieved, resulting in a confidentiality breach that could be leveraged for future attacks. The CVSS score of 6.8 indicates moderate severity; the low EPSS mitigates the overall threat relative to actively exploited vulnerabilities.

Generated by OpenCVE AI on October 3, 2026 at 17:21 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Loco Translate plugin to version 2.8.9 or later so that path validation is enforced on translation file routes.
  • Restrict the WordPress translator role so that only trusted administrators retain the capability, removing the role from public or low‑trust user accounts.
  • Configure file system permissions so that application files and configuration files are not readable by the web server user or the plugin’s file‑handling process.

Generated by OpenCVE AI on October 3, 2026 at 17:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 04 Oct 2026 22:15:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions loco Translate
Vendors & Products Wordpress-extensions
Wordpress-extensions loco Translate

Sat, 03 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 6.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N'}

ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sat, 03 Oct 2026 09:15:00 +0000

Type Values Removed Values Added
Weaknesses CWE-22

Sat, 03 Oct 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Loco Translate WordPress plugin before 2.8.9 does not restrict which file paths its translation file routes will read, allowing users granted the Loco Translate WordPress plugin before 2.8.9's translator capability to retrieve the contents of files of certain types from anywhere on the server, including outside the web root.
Title Loco Translate < 2.8.9 - Translator+ Limited File Read via 'path' Parameter
References

Subscriptions

Wordpress-extensions Loco Translate
cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-03T15:12:21.040Z

Reserved: 2026-09-21T08:00:51.121Z

Link: CVE-2026-94238

cve-icon Vulnrichment

Updated: 2026-10-03T15:00:07.039Z

cve-icon NVD

Status : Deferred

Published: 2026-10-03T06:16:47.123

Modified: 2026-10-06T15:18:12.170

Link: CVE-2026-94238

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-04T20:50:33Z

Weaknesses
  • CWE-22

    Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')