Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Stiofan UsersWP userswp allows Reflected XSS.This issue affects UsersWP: from n/a through 1.2.73.
Published: 2026-10-09
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross‑Site Scripting, potentially allowing arbitrary JavaScript execution in the context of affected users
Action: Apply Patch
AI Analysis

Impact

UsersWP plugin versions up to 1.2.73 contain a reflected cross‑site scripting flaw that occurs when user supplied input is not properly neutralized before being sent to the browser. An attacker can craft a URL or form submission that injects malicious JavaScript, which is then executed by any browser that renders the affected page. This can lead to session hijacking, credential theft, defacement, or further malware delivery. The weakness is identified as insecure input handling (CWE‑79).

Affected Systems

The vulnerability affects the WordPress UsersWP plugin from the earliest publicly released version through 1.2.73 inclusive. Hosts running any of these versions on a WordPress site, regardless of the WordPress core version, are at risk. The plugin is commonly used for user management and profile display, so many WordPress installations could be impacted.

Risk and Exploitability

With a CVSS score of 7.1, the vulnerability is rated high severity. The EPSS score is not provided, so the current exploitation probability cannot be quantified, but reflected XSS is generally easy to exploit without special prerequisites, especially when the plugin accepts query parameters or user‑controlled content. The vulnerability is not listed in the CISA KEV catalog, indicating no known mass exploitation yet. An attacker could simply rely on the victim visiting a crafted URL or clicking a malicious link that includes the injection, making the risk significant for sites with open access to the affected plugin pages.

Generated by OpenCVE AI on October 9, 2026 at 11:42 UTC.

Remediation

Vendor Solution

Update the WordPress UsersWP plugin to the latest available version (at least 1.2.74).


OpenCVE Recommended Actions

  • Update the WordPress UsersWP plugin to 1.2.74 or later, which removes the XSS vector.
  • If an update is not immediately possible, block or filter <script> tags and other risky payloads using a web‑application firewall or by adding a content‑security‑policy header that disallows inline scripts.
  • Perform a site‑wide search for any remaining unsanitized output from the plugin in custom theme or plugin files, and sanitize or escape the data before rendering it in HTML.

Generated by OpenCVE AI on October 9, 2026 at 11:42 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 09 Oct 2026 10:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Stiofan UsersWP userswp allows Reflected XSS.This issue affects UsersWP: from n/a through 1.2.73.
Title WordPress UsersWP plugin <= 1.2.73 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-11T11:42:56.522Z

Reserved: 2026-09-21T23:00:10.114Z

Link: CVE-2026-94641

cve-icon Vulnrichment

Updated: 2026-10-11T11:35:29.705Z

cve-icon NVD

Status : Deferred

Published: 2026-10-09T10:16:41.020

Modified: 2026-10-11T12:17:29.727

Link: CVE-2026-94641

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T11:45:04Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')